Package Details: lxpolkit-git 1:0.1.0.r34.g55fc5d4-3

Git Clone URL: https://aur.archlinux.org/lxpolkit-git.git (read-only)
Package Base: lxpolkit-git
Description: Simple polkit authentication agent for LXDE
Upstream URL: http://blog.lxde.org/?p=674
Licenses: GPL
Groups: lxde
Conflicts: lxpolkit
Provides: lxpolkit
Submitter: None
Maintainer: bidulock
Last Packager: bidulock
Votes: 26
Popularity: 0.000045
First Submitted: 2010-03-30 17:18
Last Updated: 2015-10-05 22:05

Latest Comments

cokomoko commented on 2015-09-29 13:27

==> build() işlemine başlanıyor...
Unescaped left brace in regex is deprecated, passed through in regex; marked by <-- HERE in m/\${ <-- HERE ([^ \t=:+{}]+)}/ at /usr/sbin/automake line 3936.

You must have automake > 1.10 or 1.11 installed to compile this program.
Install the appropriate package for your distribution,
or get the source tarball at http://ftp.gnu.org/gnu/automake/
==> HATA: build() içinde bir hata oluştu.
Çıkılıyor...
┌─[cokomoko]──[cokomoko]:/tmp/yaourt-tmp-cokomoko/aur-lxpolkit-git$
└──>>pacman -Ss automake
core/automake 1.15-1 (base-devel) [kurulu]
A GNU tool for automatically creating Makefiles

please update package

bidulock commented on 2013-03-05 16:18

automake in core is at 1.13.1. The autogen.patch needs to be changed to include 1.13 in the check to compile this package with a current system. Did somebody take ownership of this package?

hatred commented on 2012-11-12 23:45

Hi guys!

I am currently does not have interest to support this package, so I disown it. Who want can take it.

eworm commented on 2012-11-09 13:34

kaszak696 is right... hatred, would be great if you could update the package.

Anonymous comment on 2012-11-01 23:07

Managed to make it compile, not sure if it works properly though.
PKGBUILD: http://pastebin.com/V561Cj3i
autogen.patch: http://pastebin.com/hJLg2VFV

hatred commented on 2012-08-26 22:30

Hmmm... Very strange. I don't have clean machine now to test build from scratch, but on my work system all built well

paulbarbee commented on 2012-08-24 17:45

At least it fails differently with the --add-missing arg. ;-)


==> Starting make...
patching file configure.ac
configure.ac: error: no proper invocation of AM_INIT_AUTOMAKE was found.
configure.ac: You should verify that configure.ac invokes AM_INIT_AUTOMAKE,
configure.ac: that aclocal.m4 is present in the top-level directory,
configure.ac: and that aclocal.m4 was recently regenerated (using aclocal)
Makefile.am: installing './INSTALL'
configure.ac:11: error: required file 'config.h.in' not found
data/ui/Makefile.am:15: warning: '%'-style pattern rules are a GNU make extension
src/Makefile.am:11: warning: compiling 'lxpolkit.c' with per-target flags requires 'AM_PROG_CC_C_O' in 'configure.ac'
src/Makefile.am: installing './depcomp'
/usr/share/automake-1.12/am/depend2.am: error: am__fastdepCC does not appear in AM_CONDITIONAL
/usr/share/automake-1.12/am/depend2.am: The usual way to define 'am__fastdepCC' is to add 'AC_PROG_CC'
/usr/share/automake-1.12/am/depend2.am: to 'configure.ac' and run 'aclocal' and 'autoconf' again
/usr/share/automake-1.12/am/depend2.am: error: AMDEP does not appear in AM_CONDITIONAL
/usr/share/automake-1.12/am/depend2.am: The usual way to define 'AMDEP' is to add one of the compiler tests
/usr/share/automake-1.12/am/depend2.am: AC_PROG_CC, AC_PROG_CXX, AC_PROG_OBJC, AC_PROG_OBJCXX,
/usr/share/automake-1.12/am/depend2.am: AM_PROG_AS, AM_PROG_GCJ, AM_PROG_UPC
/usr/share/automake-1.12/am/depend2.am: to 'configure.ac' and run 'aclocal' and 'autoconf' again
==> ERROR: A failure occurred in build().

hatred commented on 2012-08-24 03:24

@paulbarbee, try to add --add-missing arg to automake in PKGBUILD and report result.

paulbarbee commented on 2012-08-23 20:21

I get the following when trying to build this package:

src/Makefile.am: error: required file './depcomp' not found
src/Makefile.am: 'automake --add-missing' can install 'depcomp'
/usr/share/automake-1.12/am/depend2.am: error: am__fastdepCC does not appear in AM_CONDITIONAL
/usr/share/automake-1.12/am/depend2.am: The usual way to define 'am__fastdepCC' is to add 'AC_PROG_CC'
/usr/share/automake-1.12/am/depend2.am: to 'configure.ac' and run 'aclocal' and 'autoconf' again
/usr/share/automake-1.12/am/depend2.am: error: AMDEP does not appear in AM_CONDITIONAL
/usr/share/automake-1.12/am/depend2.am: The usual way to define 'AMDEP' is to add one of the compiler tests
/usr/share/automake-1.12/am/depend2.am: AC_PROG_CC, AC_PROG_CXX, AC_PROG_OBJC, AC_PROG_OBJCXX,
/usr/share/automake-1.12/am/depend2.am: AM_PROG_AS, AM_PROG_GCJ, AM_PROG_UPC
/usr/share/automake-1.12/am/depend2.am: to 'configure.ac' and run 'aclocal' and 'autoconf' again
==> ERROR: A failure occurred in build().

hatred commented on 2012-08-22 23:17

@DarkSniper, fixed build with latest automake. Try now :-)

SirWuffleton commented on 2012-05-07 20:46

This package no longer compiles with automake 1.12-1

The build fails with this output:
==> Starting make...

You must have automake > 1.10 or 1.11 installed to compile this program.
Install the appropriate package for your distribution,
or get the source tarball at http://ftp.gnu.org/gnu/automake/
==> ERROR: A failure occurred in build().
Aborting...
The build failed.

falconindy commented on 2011-02-13 15:57

This package should be using the configure flag --libexecdir=/usr/lib. Arch follows FHS, which does not specify /usr/libexec.