Package Details: lxqt-desktop-git 0.13.0-1

Git Clone URL: https://aur.archlinux.org/lxqt-desktop-git.git (read-only)
Package Base: lxqt-desktop-git
Description: The LXQt desktop
Upstream URL: http://lxqt.org
Licenses: GPL2
Conflicts: lxqt-desktop
Provides: lxqt-desktop
Submitter: jleclanche
Maintainer: m4sk1n
Last Packager: m4sk1n
Votes: 72
Popularity: 0.000000
First Submitted: 2014-03-23 13:45
Last Updated: 2018-07-07 13:03

Dependencies (29)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 Next › Last »

mariojuniorjp commented on 2014-07-06 19:10

I can not compile the package "libqtxdg-qt5-git", because the system can not download the package. What's wrong with the package?

gruppenpest commented on 2014-07-02 10:45

I'm running into this warning with qt5 installed but without qt4:

CMake Warning at /usr/share/cmake-3.0/Modules/FindQt4.cmake:616 (message):
/usr/bin/qmake reported QT_INSTALL_LIBS as "/usr/lib" but QtCore could not
be found there. Qt is NOT installed correctly for the target build
environment.
Call Stack (most recent call first):
src/CMakeLists.txt:2 (find_package)
CMake Error at /usr/share/cmake-3.0/Modules/FindQt4.cmake:621 (message):
Could NOT find QtCore. Check

Wherefore this dependency? With qt4 installed it works fine, but tells me it's ignoring qt5:

CMake Warning:
Manually-specified variables were not used by the project:
USE_QT5

What am I missing here?

ArthurBorsboom commented on 2014-06-28 22:53

Yep, that was it.
Yaourt told me it was up to date, while it was not.

Thx

jleclanche commented on 2014-06-28 22:50

You need to update liblxqt-git.

ArthurBorsboom commented on 2014-06-28 22:49

These packages complain about it:

aur/lxqt-common-git 0.7.0.6.g8ba2ee1-1 -> 0.7.0.8.g45f55ff-1
aur/lxqt-config-git 0.7.0.5.g80f275c-1 -> 0.7.0.11.g0b34f64-1
aur/lxqt-desktop-git 0.7.0.4.g6a459b4-1 -> 0.7.0.5.g2699d0f-1
aur/lxqt-openssh-askpass-git 0.7.0.1.g1229a49-1 -> 0.7.0.2.g3ea429e-1
aur/lxqt-panel-git 0.7.0.25.ga0baafe-1 -> 0.7.0.39.gf4b2ef6-1
aur/lxqt-policykit-git 0.7.0.1.gceee868-1 -> 0.7.0.5.g081a7ff-1
aur/lxqt-powermanagement-git 0.7.0.11.g5617222-1 -> 0.7.0.13.g29b815f-1
aur/lxqt-qtplugin-git 0.7.0.6.g7613c4b-1 -> 0.7.0.7.ge46c08b-1
aur/lxqt-runner-git 0.7.0.4.g779e7c5-1 -> 0.7.0.5.g581b924-1

ArthurBorsboom commented on 2014-06-28 22:48

...
-- Detecting CXX compiler ABI info - done
CMake Error at CMakeLists.txt:24 (find_package):
By not providing "Findlxqt-qt5.cmake" in CMAKE_MODULE_PATH this project has
asked CMake to find a package configuration file provided by "lxqt-qt5",
but CMake did not find one.

Could not find a package configuration file provided by "lxqt-qt5" with any
of the following names:

lxqt-qt5Config.cmake
lxqt-qt5-config.cmake

Add the installation prefix of "lxqt-qt5" to CMAKE_PREFIX_PATH or set
"lxqt-qt5_DIR" to a directory containing one of the above files. If
"lxqt-qt5" provides a separate development package or SDK, be sure it has
been installed.


-- Configuring incomplete, errors occurred!
...

jleclanche commented on 2014-06-28 22:48

lxqt-qt5?

ArthurBorsboom commented on 2014-06-28 22:47

It helped, but then the next one popped up.

I needed to install qt5-script too.

Now I am stuck at lxqt-qt5 which all the other packages need.
However, I can't find this one in AUR.

Any suggestions?

jleclanche commented on 2014-06-28 22:38

Try installing qt5-x11extras.

It should be required by liblxqt-git. The downside of using most AUR wrappers is they don't update the libraries first so you get these issues when some cross-deps change.

ArthurBorsboom commented on 2014-06-28 22:38

To be more precise:

CMake Error at CMakeLists.txt:20 (find_package):
By not providing "FindQt5X11Extras.cmake" in CMAKE_MODULE_PATH this project
has asked CMake to find a package configuration file provided by
"Qt5X11Extras", but CMake did not find one.

Could not find a package configuration file provided by "Qt5X11Extras" with
any of the following names:

Qt5X11ExtrasConfig.cmake
qt5x11extras-config.cmake

Add the installation prefix of "Qt5X11Extras" to CMAKE_PREFIX_PATH or set
"Qt5X11Extras_DIR" to a directory containing one of the above files. If
"Qt5X11Extras" provides a separate development package or SDK, be sure it
has been installed.