Package Details: lxqt-notificationd-git 0.9.0.14.g41a22ef-1

Git Clone URL: https://aur.archlinux.org/lxqt-notificationd-git.git (read-only)
Package Base: lxqt-notificationd-git
Description: LXQt notification daemon and library.
Upstream URL: http://lxqt.org
Licenses: GPL2
Conflicts: lxqt-notificationd
Provides: lxqt-notificationd
Submitter: jleclanche
Maintainer: jleclanche
Last Packager: jleclanche
Votes: 37
Popularity: 0.041058
First Submitted: 2013-10-24 00:55
Last Updated: 2015-08-30 21:39

Latest Comments

JKAbrams commented on 2015-07-22 22:08

Changeing:
#include <SysStat/CpuStat>
#include <SysStat/MemStat>
#include <SysStat/NetStat>

into:
#include <sysstat-qt5/SysStat/CpuStat>
#include <sysstat-qt5/SysStat/MemStat>
#include <sysstat-qt5/SysStat/NetStat>

in the files:
lxqt-panel-git/src/lxqt-panel/plugin-sysstat/lxqtsysstat.cpp
lxqt-panel-git/src/lxqt-panel/plugin-sysstat/lxqtsysstatconfiguration.cpp

fixes the problem.

JKAbrams commented on 2015-07-22 21:49

I spoke too soon:
lxqt-panel-git/src/lxqt-panel/plugin-sysstat/lxqtsysstat.cpp:31:27: fatal error: SysStat/CpuStat: No such file or directory
compilation terminated.

JKAbrams commented on 2015-07-22 21:46

libsysstat just need to be install and then it builds, should be in build-dep.

JKAbrams commented on 2015-07-22 21:34

-- Network Monitor plugin requires libstatgrab
--
CMake Error at plugin-sysstat/CMakeLists.txt:3 (find_package):
By not providing "FindSysStat-Qt5.cmake" in CMAKE_MODULE_PATH this project
has asked CMake to find a package configuration file provided by
"SysStat-Qt5", but CMake did not find one.

Could not find a package configuration file provided by "SysStat-Qt5" with
any of the following names:

SysStat-Qt5Config.cmake
sysstat-qt5-config.cmake

Add the installation prefix of "SysStat-Qt5" to CMAKE_PREFIX_PATH or set
"SysStat-Qt5_DIR" to a directory containing one of the above files. If
"SysStat-Qt5" provides a separate development package or SDK, be sure it
has been installed.

flexiondotorg commented on 2014-05-09 13:35

Please add `liblxqt-git` to `depends` as `namcap` reports the following:

lxqt-notificationd-git E: Dependency liblxqt-git detected and not included (libraries ['usr/lib/liblxqt.so.0'] needed in files ['usr/bin/lxqt-notificationd', 'usr/bin/lxqt-config-notificationd'])

jleclanche commented on 2014-05-06 22:15

@Alister.Hood Thanks, I'll add the dependency.

Alister.Hood commented on 2014-05-06 22:05

I just get this error message in the terminal, and a black rectangle instead of a notification, unless I install lxqt-common-git:
Theme: Cannot open file for reading: "/lxqt-notificationd.qss"