Package Details: lxqt-panel-git 0.13.0.1104.gc6f910fd-1

Git Clone URL: https://aur.archlinux.org/lxqt-panel-git.git (read-only)
Package Base: lxqt-panel-git
Description: The LXQt desktop panel
Upstream URL: https://github.com/lxde/lxqt-panel
Licenses: GPL2
Conflicts: lxqt-panel
Provides: lxqt-panel
Submitter: jleclanche
Maintainer: pmattern
Last Packager: pmattern
Votes: 46
Popularity: 0.000013
First Submitted: 2013-10-24 01:13
Last Updated: 2018-12-15 22:21

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 Next › Last »

jleclanche commented on 2014-07-05 14:12

Reinstall all of lxqt from the beginning. In your case, you need to rebuild lxqt-mount-git before rebuilding lxqt-panel.

sh4nks commented on 2014-07-05 06:27

Cannot compile this package.
I'm getting this error:
-- Building with Qt5.3.1
CMake Error at CMakeLists.txt:80 (find_package):
By not providing "Findlxqtmount-qt5.cmake" in CMAKE_MODULE_PATH this
project has asked CMake to find a package configuration file provided by
"lxqtmount-qt5", but CMake did not find one.

Could not find a package configuration file provided by "lxqtmount-qt5"
with any of the following names:

lxqtmount-qt5Config.cmake
lxqtmount-qt5-config.cmake

Add the installation prefix of "lxqtmount-qt5" to CMAKE_PREFIX_PATH or set
"lxqtmount-qt5_DIR" to a directory containing one of the above files. If
"lxqtmount-qt5" provides a separate development package or SDK, be sure it
has been installed.


-- Configuring incomplete, errors occurred!

warlock commented on 2014-05-10 20:39

Hi compilation stop at lxqt-panel-git for me, anyone have this problem ?

Run Build Command:/usr/bin/make "cmTryCompileExec3919568318/fast"
/usr/bin/make -f CMakeFiles/cmTryCompileExec3919568318.dir/build.make CMakeFiles/cmTryCompileExec3919568318.dir/build
make[1]: Entering directory '/root/pack/lxqt-panel-git/src/lxqt-panel/build/CMakeFiles/CMakeTmp'
/usr/bin/cmake -E cmake_progress_report /root/pack/lxqt-panel-git/src/lxqt-panel/build/CMakeFiles/CMakeTmp/CMakeFiles 1
Building CXX object CMakeFiles/cmTryCompileExec3919568318.dir/CheckSymbolExists.cxx.o
/usr/bin/c++ -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -fvisibility=hidden -fvisibility-inlines-hidden -fno-exceptions -I/usr/include/qt4 -o$
/root/pack/lxqt-panel-git/src/lxqt-panel/build/CMakeFiles/CMakeTmp/CheckSymbolExists.cxx: In function âint main(int, char**)â:
/root/pack/lxqt-panel-git/src/lxqt-panel/build/CMakeFiles/CMakeTmp/CheckSymbolExists.cxx:8:19: error: âQ_WS_WINâ was not declared in this scope
return ((int*)(&Q_WS_WIN))[argc];
^
CMakeFiles/cmTryCompileExec3919568318.dir/build.make:60: recipe for target 'CMakeFiles/cmTryCompileExec3919568318.dir/CheckSymbolExists.cxx.o' failed
make[1]: *** [CMakeFiles/cmTryCompileExec3919568318.dir/CheckSymbolExists.cxx.o] Error 1
make[1]: Leaving directory '/root/pack/lxqt-panel-git/src/lxqt-panel/build/CMakeFiles/CMakeTmp'
Makefile:117: recipe for target 'cmTryCompileExec3919568318/fast' failed
make: *** [cmTryCompileExec3919568318/fast] Error 2

jleclanche commented on 2014-05-10 14:29

Good point.

TZ86 commented on 2014-05-10 14:06

>pulseaudio: Recompile for PulseAudio support in volume control plugin

You should replace "pulseaudio" to "libpulse" because it's a package which provides all headers, cmake and pkgconfig files.

% pkgfile /usr/lib/cmake/PulseAudio/PulseAudioConfig.cmake
extra/libpulse
% pkgfile /usr/include/pulse/*.h
extra/libpulse

flexiondotorg commented on 2014-05-09 13:38

Please add `libxdamage` to `depends` as `namcap` reports the following:

lxqt-panel-git E: Dependency libxdamage detected and not included (libraries ['usr/lib/libXdamage.so.1'] needed in files ['usr/lib/lxqt-panel/libtray.so'])

cygoh commented on 2014-05-08 06:34

As commented by gripped, without libxcomposite build failed.

goetzc commented on 2014-04-25 05:08

Shouldn't this package depend on menu-cache-git? I get this 'package not found':

-- checking for module 'libmenu-cache>=0.3.3'
-- package 'libmenu-cache>=0.3.3' not found

Also, pacaur and yaourt don't understand the provides= parameter, so the dependency should be libsysstat-git instead of libsysstat (as other people suggest).

AlexTalker commented on 2014-04-24 17:01

Bug in depends, fixed version here https://gist.github.com/11261812

gripped commented on 2014-03-25 10:05

depends( or make depends ?) on libxcomposite