Package Details: ly2video-git 0.5.0.r0.g41364ad-1

Git Clone URL: (read-only, click to copy)
Package Base: ly2video-git
Description: Generate videos from Lilypond sheet music files
Upstream URL:
Licenses: GPL3
Conflicts: ly2video
Provides: ly2video
Submitter: Beacon515L
Maintainer: eclairevoyant
Last Packager: eclairevoyant
Votes: 3
Popularity: 0.000000
First Submitted: 2017-04-17 06:20 (UTC)
Last Updated: 2023-05-21 10:52 (UTC)

Latest Comments

redtide commented on 2023-05-21 07:57 (UTC)

@eclairevoyant Feel free to maintain the package and make the necessary changes

eclairevoyant commented on 2023-05-21 02:44 (UTC)

Dependencies have changed; see my package for reference.

Also, custom variables should always begin with underscore (not end with them) as per the packaging guidelines (i.e. you should use _pkgname not pkgname_)

After making the above changes, note that upstream has versioned releases, so the pkgver should reflect this:

pkgver() {
    git -C $_pkgname describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'

which produces the expected 0.5.0.r0.g41364ad

dreieck commented on 2021-04-24 19:23 (UTC)

Dependency python2-pypdf is no longer available:

 -> Could not find all required packages:
        python2-pypdf (Wanted by: ly2video-git)

Please consider switching to python3 as commented on 2021-01-17, and update the dependencies.

Thanks for maintaining!

profejuanca commented on 2021-04-21 13:33 (UTC)

Thanks @jeandeaual

jeandeaual commented on 2021-01-17 11:01 (UTC) (edited on 2021-01-17 11:02 (UTC) by jeandeaual)

ly2video now supports Python 3 (

You should be able to replace all python2 dependencies: python2-imaging → python-pillow, python2-midi → python-midi (provided by python-midi-git), python2-pip → python-pip, python2-pypdf → python-pypdf

skuzzymiglet commented on 2020-05-17 11:44 (UTC)

The dependencies need to be updated, according to

archmylinux commented on 2017-07-12 18:38 (UTC)

Thanks @Beacon515L, I posted an issue here :

Beacon515L commented on 2017-06-28 07:32 (UTC)

@archmylinux, Lilypond 2.19.63 isn't available anywhere - upstream is still at 2.19.62, which lilypond-git and lilypond-devel both provide - community/lilypond currently provides 2.18.2. There is a small chance lilypond-git's pkgver() isn't playing nice; try lilypond-devel? I'll see if upstream has anything to say about your issue, thanks for posting it. There is apparently some issue to do with paths and may have to do with the fact that there is a file called, from a cursory Google search. I haven't been able to replicate the bug on my own system, so I might try building it on a clean system.

archmylinux commented on 2017-06-22 15:00 (UTC) (edited on 2017-06-22 15:11 (UTC) by archmylinux)

Same here @jonarnold. Somehow, does not have access to the module utils. I'll post an issue upstream. On a side note, I also had to remove the >=2.15.xx in the make package. I currently use 2.19.63.

jonarnold commented on 2017-06-21 14:35 (UTC) (edited on 2017-06-21 14:40 (UTC) by jonarnold)

I'm getting an error after installing: File "/usr/bin/", line 47, in <module> from utils import * ImportError: No module named utils Perhaps there's a missing dependency? Also, my system keeps saying that the package needs updating, which is odd.