Package Details: ly2video-git r429.c63cc1b-1

Git Clone URL: https://aur.archlinux.org/ly2video-git.git (read-only, click to copy)
Package Base: ly2video-git
Description: A script to generate a video from a Lilypond sheet music file
Upstream URL: https://github.com/aspiers/ly2video
Licenses: GPL3
Conflicts: ly2video
Provides: ly2video
Submitter: Beacon515L
Maintainer: redtide
Last Packager: redtide
Votes: 3
Popularity: 0.039616
First Submitted: 2017-04-17 06:20
Last Updated: 2021-06-08 12:01

Latest Comments

dreieck commented on 2021-04-24 19:23

Dependency python2-pypdf is no longer available:

 -> Could not find all required packages:
        python2-pypdf (Wanted by: ly2video-git)

Please consider switching to python3 as commented on 2021-01-17, and update the dependencies.

Thanks for maintaining!

profejuanca commented on 2021-04-21 13:33

Thanks @jeandeaual

jeandeaual commented on 2021-01-17 11:01

ly2video now supports Python 3 (https://github.com/aspiers/ly2video/pull/91).

You should be able to replace all python2 dependencies: python2-imaging → python-pillow, python2-midi → python-midi (provided by python-midi-git), python2-pip → python-pip, python2-pypdf → python-pypdf

skuzzymiglet commented on 2020-05-17 11:44

The dependencies need to be updated, according to https://github.com/aspiers/ly2video/issues/89.

archmylinux commented on 2017-07-12 18:38

Thanks @Beacon515L,

I posted an issue here :
https://github.com/aspiers/ly2video/issues/66

Beacon515L commented on 2017-06-28 07:32

@archmylinux, Lilypond 2.19.63 isn't available anywhere - upstream is still at 2.19.62, which lilypond-git and lilypond-devel both provide - community/lilypond currently provides 2.18.2. There is a small chance lilypond-git's pkgver() isn't playing nice; try lilypond-devel?

I'll see if upstream has anything to say about your issue, thanks for posting it. There is apparently some issue to do with paths and may have to do with the fact that there is a file called utils.py, from a cursory Google search. I haven't been able to replicate the bug on my own system, so I might try building it on a clean system.

archmylinux commented on 2017-06-22 15:00

Same here @jonarnold.

Somehow, ly2video.py does not have access to the module utils. I'll post an issue upstream.

On a side note, I also had to remove the >=2.15.xx in the make package. I currently use 2.19.63.

jonarnold commented on 2017-06-21 14:35

I'm getting an error after installing:
File "/usr/bin/ly2video.py", line 47, in <module>
from utils import *
ImportError: No module named utils

Perhaps there's a missing dependency? Also, my system keeps saying that the package needs updating, which is odd.