Package Details: lychee-photo-management 4.13.0-1

Git Clone URL: https://aur.archlinux.org/lychee-photo-management.git (read-only, click to copy)
Package Base: lychee-photo-management
Description: Easy to use and great looking photo management system
Upstream URL: https://lycheeorg.github.io/
Licenses: MIT
Submitter: polyzen
Maintainer: eclairevoyant
Last Packager: eclairevoyant
Votes: 6
Popularity: 0.000000
First Submitted: 2023-02-23 05:17 (UTC)
Last Updated: 2023-09-24 16:37 (UTC)

Latest Comments

1 2 Next › Last »

MrBlumi commented on 2023-05-25 09:26 (UTC) (edited on 2023-06-16 10:16 (UTC) by MrBlumi)

Would you mind declaring mariadb as an optional dependency and adding postgresql as an optional dependency as well?

Lychee supports MySQL/MariaDB, PostgreSQL and SQLite3 and thus I would not want to bake a hard dependency onto one of them into the package. In addition I would not expect the user to even install any of these on the same server where Lychee is installed ;)

Edit: Thanks!

eschwartz commented on 2021-01-11 20:23 (UTC)

Hi, Trusted User here speaking officially.

ilpianista is correct here. You must not use pkgver() like this under any circumstances; as it is, this PKGBUILD and many other PKGBUILDs you maintain are in strict violation of the packaging standards. Please fix them immediately.

If you want to keep track of new versions, I recommend you use something like nvchecker to scrape github for new versions of many packages at once, and a personal script which runs sed to insert the updated version into the PKGBUILD.

Abzie commented on 2020-11-20 19:49 (UTC) (edited on 2020-11-20 19:50 (UTC) by Abzie)

Found lychee-4.0.5.tar.gz

...

Making package: lychee 4.0.8-1

Please fix your PKGBUILD :)

Fanch commented on 2020-04-02 20:52 (UTC)

yes you're right ;)

ilpianista commented on 2020-04-02 13:39 (UTC)

and which defeat the purpose of a checksum check in the first place..

Fanch commented on 2020-04-02 13:18 (UTC)

you can update the checksum with the command: updpkgsums

before running makepkg, so it will auto-update version and checksum

Here is how I do it: https://github.com/FanchTheSystem/Aur-Include/blob/e8478060d44971f558cdab280f1f1a7129ff9e09/aur.include.sh#L47

ilpianista commented on 2020-04-02 12:37 (UTC)

I got it, but you still have to update the checksum in the PKGBUILD (in the case of a newer version) so I don't see the advantage here.

Fanch commented on 2020-04-02 12:34 (UTC)

ah ah evil is every where :)

pkgver is used to auto use and update the last availlable version ;)

ilpianista commented on 2020-04-02 12:30 (UTC)

Also, please update the website, it's: https://lycheeorg.github.io/

Tio commented on 2020-04-02 12:29 (UTC)

Works. Thanks