Package Details: mach64drm 5.6-1

Git Clone URL: https://aur.archlinux.org/mach64drm.git (read-only, click to copy)
Package Base: mach64drm
Description: Mach64 DRM module
Upstream URL: http://dri.freedesktop.org/wiki/DRM
Licenses: GPL
Submitter: lambchops468
Maintainer: trya
Last Packager: trya
Votes: 6
Popularity: 0.000000
First Submitted: 2008-06-21 14:27
Last Updated: 2020-04-24 01:09

Pinned Comments

trya commented on 2020-04-24 01:10

Updated to build with linux 5.6. This module needs CONFIG_DRM_LEGACY to build, so you may need to rebuild your kernel with this option set.

Latest Comments

1 2 3 4 Next › Last »

trya commented on 2020-04-24 01:10

Updated to build with linux 5.6. This module needs CONFIG_DRM_LEGACY to build, so you may need to rebuild your kernel with this option set.

mbrennr commented on 2019-03-28 12:16

Module not loading on Kernel 5.0.4-arch1-1-ARCH (no surprise) modprobe: ERROR: could not insert 'mach64': Invalid argument dmesg RIP... Btw, for the associated mach64-dri (community repo) driver, add "iomem=relaxed" to kernel boot parameters. Builds ok.

trya commented on 2015-02-22 21:57

Updated sources to build with linux 3.18.

trya commented on 2014-08-30 21:20

Updated sources to build with linux 3.16.

trya commented on 2014-04-11 14:01

Updated sources to build with linux 3.14.

trya commented on 2013-12-29 18:05

Updated sources to build with linux 3.12.

trya commented on 2013-01-30 10:59

Updated sources to build with linux 3.7.

trya commented on 2012-10-18 22:09

Updated sources to build with linux 3.6.

trya commented on 2012-10-18 11:05

The code is ready for 3.6, but the Makefile has a bug in the clean target. You'll have to wait a little before the update.

trya commented on 2012-09-18 15:57

@BenoitSvB: yes, you're right, DRI support in the xorg driver came back since July 17th. The instructions in the wiki still apply.