Package Details: magic-wormhole 0.11.2-1

Git Clone URL: https://aur.archlinux.org/magic-wormhole.git (read-only)
Package Base: magic-wormhole
Description: Securely transfer data between computers
Upstream URL: https://pypi.python.org/pypi/magic-wormhole/0.11.2
Licenses: MIT
Conflicts: python-wormhole, wormhole, wormhole-server
Provides: python-wormhole, wormhole, wormhole-server
Replaces: python-wormhole, wormhole, wormhole-server
Submitter: stormdragon2976
Maintainer: stormdragon2976
Last Packager: stormdragon2976
Votes: 23
Popularity: 1.728123
First Submitted: 2016-08-10 22:29
Last Updated: 2019-03-30 12:27

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

trickyelf commented on 2018-12-07 04:25

I have downloaded this package and attempted to install it via "makepkg -sri" (not with a helper). It results in an error:

$ makepkg -sri
...
==> Creating package "python-magic-wormhole"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: magic-wormhole 0.11.2-1 (Thu 06 Dec 2018 08:25:13 PM PST)
==> Installing magic-wormhole package group with pacman -U...
loading packages...
resolving dependencies...
looking for conflicting packages...
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: python2-magic-wormhole and python-magic-wormhole are in conflict
==> WARNING: Failed to install built package(s).

How do I use this pkgbuild?

aurelieng commented on 2018-11-20 14:11

I'm trying to install magic-wormhole. yay reports dependencies that can't be found here in AUR but are nevertheless mentioned in the PKGBUILD:

  • python2-autobahn
  • python2-tqdm
  • python2-spake2

Additionally, I haven't been able to install python2-hkdf (Could not find PKGDEST for: python2-hkdf).

I looked at the PKGBUILD and noticed that it builds both python2 and python versions. Since 1/ Arch comes with python, 2/ the python2 support prevents the installation of magic-wormhole, I wonder what's the rationale behind providing it, if it could be removed or at least maintained separately (i removed all references to python2-*, and was able to build, install and run magic-wormhole as expected)?

stormdragon2976 commented on 2018-11-03 19:24

@needle8420: sorry it took me so long to get this done. I think I got it though. Please let me know if it works as expected, or if there are any problems.

needle8420 commented on 2018-10-16 09:11

sd, thx for the quick reply

take your time, im happy with my workaround

stormdragon2976 commented on 2018-10-15 22:58

@needle8420: I have had a lot of things come up here recently, including a death in the family. So it may be a bit until I can get to this.

Can you create the split package? If so, would you like to be added as a comaintainer?

If not, please give me a couple days and I will try my best to get it done. Thanks, and sorry for the delay.

needle8420 commented on 2018-10-15 17:40

please make this a 'split package'

with pkgbase = magic-wormhole
and pkgname = python2-magic-wormhole, python-magic-wormhole

why?

cos tahoe-lafs-git needs python2-magic-wormhole
but pikaur will install the py3 version
and tahoe-lafs-git build fails with

py27 runtests: commands[0] | tahoe --version
pkg_resources.DistributionNotFound: The 'magic-wormhole>=0.10.2' distribution was not found and is required by tahoe-lafs

see
https://aur.archlinux.org/packages/tahoe-lafs-git/#comment-666876

workaround:
sudo pip2 install magic-wormhole

stormdragon2976 commented on 2018-08-10 22:27

@teras: I'm sorry you're having trouble with wormhole. I have tested it on three machines now and I can not reproduce the problem.

I have spoken with a friend of mine who also uses it, and it is broken for him. My suggestions is remove, then reinstall the package and see if that fixes it. I installed a fresh image on a Pi today and installed it, and everything works as expected. I'm able to send and receive files.

If anyone else is having this issue, please let me know. Especially if you have a fix for it too. >:-)

teras commented on 2018-08-10 13:21

For me the package doesn't work again due to txtorcon problem. Any idea how to fix it?

aexl commented on 2017-09-11 12:51

wormhole stopped working because of python-pyasn1 0.3.4-1, it requires version 0.3.3.

stormdragon2976 commented on 2017-06-27 17:32

@pigmonkey thanks for the heads up on the dependancy. I went ahead and added it to the PKGBUILD. It is, of course, broken like you said, but hopefully the txtorcon package will be fixed soon. It almost looks to me like it needs to be a split package to provide both python2-txtorcon and python3-txtorcon, but I'm not sure. I didn't spend all that much time looking at it, but when I changed the PKGBUILD to require python2-twisted, it installed, but wormhole still failed to work. If everyone is ok with waiting a couple days to see what happens with txtorcon, I'll wait and see. If, however, anyone needs it ASAP, just let me know and I'll see what I can do.