Package Details: magicassistant-gtk 1.4.2.010-1

Git Clone URL: https://aur.archlinux.org/magicassistant-gtk.git (read-only)
Package Base: magicassistant-gtk
Description: Card Browser, Library Organizer, Deck Builder and Tournament Manager for Magic the Gathering Card Game
Upstream URL: http://sourceforge.net/projects/mtgbrowser/
Licenses: EPL
Submitter: chmod777
Maintainer: None
Last Packager: Nyutag
Votes: 4
Popularity: 0.018231
First Submitted: 2012-05-06 03:42
Last Updated: 2015-06-17 08:19

Latest Comments

KozRoss commented on 2015-09-29 08:03

Needs another update, it seems - its internal updater is requesting one.

Plloi commented on 2014-12-18 22:57

Updated to 1.4.1.4, thanks for the poke on this one @Nyutag

Strit commented on 2014-11-04 18:01

ah, found my problem.
It requires openjdk-8 instead of openjdk-7. Works fine when running in java 8 environment.

Strit commented on 2014-11-04 16:48

getting this error, when running magicassistant from the terminal.

$ magicassistant

(java:463): Gtk-WARNING **: Kunne ikke finde temamotor i module_path: "adwaita",

(java:463): Gtk-WARNING **: Kunne ikke finde temamotor i module_path: "adwaita",
gogo: CommandNotFoundException: Command not found: gosh
org.apache.felix.gogo.runtime.CommandNotFoundException: Command not found: gosh
at org.apache.felix.gogo.runtime.Closure.executeCmd(Closure.java:474)
at org.apache.felix.gogo.runtime.Closure.executeStatement(Closure.java:403)
at org.apache.felix.gogo.runtime.Pipe.run(Pipe.java:108)
at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:183)
at org.apache.felix.gogo.runtime.Closure.execute(Closure.java:120)
at org.apache.felix.gogo.runtime.CommandSessionImpl.execute(CommandSessionImpl.java:89)
at org.apache.felix.gogo.shell.Activator.run(Activator.java:75)
at java.lang.Thread.run(Thread.java:745)

Any idea what could be wrong?

mirandir commented on 2012-12-07 15:32

Version 1.2.6.9 is out.

Updated version of the PKGBUILD here, if you want : https://dl.dropbox.com/u/70787217/magicassistant-gtk-1.2.6.9-1.src.tar.gz

minder commented on 2012-09-09 16:39

Does it *really* need OpenJDK? If not (I tested - it doesn't), please make it depend on 'java-runtime' instead of 'jre7-openjdk'. Some people install Oracle's JRE from AUR that provides 'java-runtime' but conflicts with OpenJDK.

Please add 'xulrunner192' dependency (see ReapSharc's comment) - without it the app doesn't start at least on x86_64.

You also entered 'libwebkit' dependency twice.

chmod777 commented on 2012-07-26 02:17

Thanks! I forgot about that. It's all set now.

Nyutag commented on 2012-07-24 07:43

So, since your package work now with x86_64, add it in your PKGBUILD => arch=(i686 x86_64). I'm asking a TU for merging comment and delete my package.

chmod777 commented on 2012-07-24 04:36

I added you as a contributer on my original magicassistant-gtk PKGBUILD. That package is now multiarch.

Anonymous comment on 2012-07-21 12:25

On x86_64, if you run into this error:
error: java.lang.NullPointerException
Job found still running after platform shutdown. Jobs should be canceled by the plugin that scheduled them during shutdown: org.eclipse.ui.internal.progress.ProgressViewUpdater$1
Job found still running after platform shutdown. Jobs should be canceled by the plugin that scheduled them during shutdown: org.eclipse.ui.internal.progress.AnimationManager$1

Install xulrunner192 (also on AUR) and that should solve this issue (in most cases).

chmod777 commented on 2012-07-07 18:15

Sorry for the delay. It's updated!

Anonymous comment on 2012-06-10 21:46

1.2.4 Has been released