Package Details: magicavoxel 0.99.7.1.r20230614-2

Git Clone URL: https://aur.archlinux.org/magicavoxel.git (read-only, click to copy)
Package Base: magicavoxel
Description: A free lightweight 8-bit voxel art editor and GPU based interactive path tracing renderer
Upstream URL: https://ephtracy.github.io/
Keywords: ephtracy magica
Licenses: custom
Submitter: skitoo
Maintainer: u32i64
Last Packager: u32i64
Votes: 11
Popularity: 1.37
First Submitted: 2017-11-15 16:31 (UTC)
Last Updated: 2023-07-09 13:14 (UTC)

Pinned Comments

u32i64 commented on 2020-04-25 11:21 (UTC) (edited on 2020-04-25 11:22 (UTC) by u32i64)

@gogoprog Thanks for the notice! Unfortunately with 0.99.5 upstream is releasing bug fixes without changing the version. I have updated the checksum in 0.99.5-4.

It looks like you first flagged the package as out-of-date but then removed the flag and posted the comment. In the future, if the checksum changes on this package, please use the "flag out-of-date" functionality to keep comments clean.

Latest Comments

u32i64 commented on 2023-07-09 13:04 (UTC) (edited on 2023-07-09 13:05 (UTC) by u32i64)

Decided to update this package to the current "beta" version 0.99.7.1, since the non-beta download links have been removed from the upstream homepage (https://github.com/ephtracy/ephtracy.github.io/commit/ba3e02bdac8c2240e33e86ae6c10ccb573a1cb23).

damax commented on 2022-12-12 17:49 (UTC) (edited on 2022-12-12 17:49 (UTC) by damax)

@u32i64 Thank you so much for the extensive information.

As for interest in having the newest update, it does appeal, and that's the main reason why I asked in the first place.

I don't know how many people use MagicaVoxel on Arch, from the AUR, but since you're already the maintainer of this package, if you would want to create a -beta one, we could certainly benefit from it.

But I'm not sure what would be the best practice, and I don't know why 0.99.7.0 is considered "beta" by ephtracy, given the long hiatus in MagicaVoxel's development.

More opinions would be welcomed.

u32i64 commented on 2022-12-12 13:55 (UTC) (edited on 2022-12-12 13:56 (UTC) by u32i64)

@damax Yes, the 0.99.7(.0) version should be pretty straightforward to install using this PKGBUILD, you should just need to change:

If you want to install it side-by-side with the current version, you may need to change the name of the package, some filenames, and edit the magicavoxel script accordingly (app_folder etc.), for it to be a fully separate installation.

On a related note, do you (or anyone else using this package) think it would make sense for me to just update this package to 0.99.7(.0)? It's true that it's considered "beta" by upstream, but given that there have not been any newer versions in a long time it might make sense to consider it a "stable enough" version in the context of this AUR package.

Otherwise, would it perhaps make sense to create a separate package with a -beta suffix that would contain such beta versions?

damax commented on 2022-12-12 11:12 (UTC)

If one wanted to package the beta version (with new features and changes), would the build process potentially be the same?

Kuro654 commented on 2022-06-22 13:26 (UTC)

This works great! Thanks :)

PedroSnow commented on 2021-11-01 20:26 (UTC)

Please, could you update the checksum for the files or change it to "skip"?

apetresc commented on 2021-09-13 02:10 (UTC)

Looks like upstream modified magicavoxel-0.99.6.4.r20210908.zip again; another checksum issue like last time. Mind releasing another pkgrel? :)

(Or perhaps just setting the checksum for that file to SKIP?)

u32i64 commented on 2020-04-25 11:21 (UTC) (edited on 2020-04-25 11:22 (UTC) by u32i64)

@gogoprog Thanks for the notice! Unfortunately with 0.99.5 upstream is releasing bug fixes without changing the version. I have updated the checksum in 0.99.5-4.

It looks like you first flagged the package as out-of-date but then removed the flag and posted the comment. In the future, if the checksum changes on this package, please use the "flag out-of-date" functionality to keep comments clean.

gogoprog commented on 2020-04-25 08:07 (UTC)

==> Validating source files with sha512sums... MagicaVoxel-0.99.5-alpha-win64.zip ... FAILED

goodytong commented on 2019-11-09 06:33 (UTC)

Please pull from https://github.com/goodyttoor/aur_magicavoxel.git for version 0.99.4.2 with plugins