Package Details: magics++ 2.34.1-4

Git Clone URL: https://aur.archlinux.org/magics++.git (read-only)
Package Base: magics++
Description: Magics is the latest generation of the ECMWF's Meteorological plotting software MAGICS.
Upstream URL: https://software.ecmwf.int/wiki/display/MAGP
Licenses: Apache
Submitter: graziano
Maintainer: graziano
Last Packager: graziano
Votes: 1
Popularity: 0.903833
First Submitted: 2016-03-28 17:02
Last Updated: 2017-07-20 12:44

Latest Comments

OvelixMax commented on 2017-06-11 01:38

@graziano, thank you for the answer... I reinstall eccodes before try to update magics++, but a new error appear now.

[ 99%] Linking CXX executable ../../bin/metgramx
CMakeFiles/metgramx.dir/metgramx.cc.o: En la función `TempFile::TempFile()':
/tmp/yaourt-tmp-ovel/aur-magics++/src/Magics-2.33.0-Source/apps/metgram/metgramx.cc:70: aviso: the use of `tmpnam' is dangerous, better use `mkstemp'
../../lib/libMagPlus.so: referencia a `NcVar::get(unsigned char*, long const*) const' sin definir
collect2: error: ld devolvió el estado de salida 1
make[2]: *** [apps/metgram/CMakeFiles/metgramx.dir/build.make:129: bin/metgramx] Error 1
make[1]: *** [CMakeFiles/Makefile2:2204: apps/metgram/CMakeFiles/metgramx.dir/all] Error 2
make: *** [Makefile:163: all] Error 2
==> ERROR: Se produjo un fallo en build().
Cancelando…
==> ERROR: Makepkg no ha podido compilar magics++.
==> ¿Reiniciar la compilación de magics++? [s/N]

graziano commented on 2017-06-10 06:44

@OvelixMax, you need to recompile libeccodes because on your system gfortran has been upgraded.

OvelixMax commented on 2017-06-09 18:27

I have problem to compile the last version.

This is at the end of the compilation:

[ 99%] Generating _Magics.so
running build_ext
[ 99%] Built target build_swig_wrapper
[ 99%] Linking CXX executable ../../bin/metgramx
CMakeFiles/metgramx.dir/metgramx.cc.o: En la función `TempFile::TempFile()':
/tmp/yaourt-tmp-ovel/aur-magics++/src/Magics-2.33.0-Source/apps/metgram/metgramx.cc:70: aviso: the use of `tmpnam' is dangerous, better use `mkstemp'
/usr/bin/ld: warning: libgfortran.so.3, needed by /usr/lib/libeccodes_f90.so, not found (try using -rpath or -rpath-link)
/usr/lib/libeccodes_f90.so: referencia a `_gfortran_internal_unpack@GFORTRAN_1.0' sin definir
/usr/lib/libeccodes_f90.so: referencia a `_gfortran_internal_pack@GFORTRAN_1.0' sin definir
/usr/lib/libeccodes_f90.so: referencia a `_gfortran_os_error@GFORTRAN_1.0' sin definir
../../lib/libMagPlus.so: referencia a `NcVar::get(unsigned char*, long const*) const' sin definir
/usr/lib/libeccodes_f90.so: referencia a `_gfortran_concat_string@GFORTRAN_1.0' sin definir
collect2: error: ld devolvió el estado de salida 1
make[2]: *** [apps/metgram/CMakeFiles/metgramx.dir/build.make:129: bin/metgramx] Error 1
make[1]: *** [CMakeFiles/Makefile2:2204: apps/metgram/CMakeFiles/metgramx.dir/all] Error 2
make: *** [Makefile:163: all] Error 2
==> ERROR: Se produjo un fallo en build().
Cancelando…
==> ERROR: Makepkg no ha podido compilar magics++.
==> ¿Reiniciar la compilación de magics++? [s/N]

I don't have libgfortran.so.3, I have libgfortran.so.4 that came from gcc-libs-multilib (7.1.1-3).

graziano commented on 2017-01-18 21:04

freetype2 error...
Check this:
https://www.ostechnix.com/fix-harfbuzz-infinality-issue-arch-linux/

tmaldo23 commented on 2017-01-18 17:31

I am having this error,

[ 99%] Linking CXX executable ../../bin/metgramx
CMakeFiles/metgramx.dir/metgramx.cc.o: In function `TempFile::TempFile()':
/home/tito/sources/magics++/src/Magics-2.30.0-Source/apps/metgram/metgramx.cc:70: warning: the use of `tmpnam' is dangerous, better use `mkstemp'
/usr/lib/libharfbuzz.so.0: undefined reference to `FT_Get_Var_Blend_Coordinates'
collect2: error: ld returned 1 exit status
make[2]: *** [apps/metgram/CMakeFiles/metgramx.dir/build.make:127: bin/metgramx] Error 1
make[1]: *** [CMakeFiles/Makefile2:2204: apps/metgram/CMakeFiles/metgramx.dir/all] Error 2
make: *** [Makefile:161: all] Error 2

kubrick commented on 2016-04-10 11:59

The pkgbuild file needs:

depends=('grib_api' 'boost' 'perl-xml-parser')

to build and run

and src/drivers/CairoDriver.cc lines 542 & 543 need to be patched (replace "." with ")" )

dumbojumbo commented on 2016-04-02 14:41

I'm unable to build the package as there is an error in
/src/driver/CairoDriver.cc
line 542 and 543. Unbalanced brackets!. I don't know how to patch this. It would be nice if someone can help me with this or if the maintainer can patch for the rest of the users. Thanks in advance!