Package Details: mailcrypt 3.5.9-6

Git Clone URL: https://aur.archlinux.org/mailcrypt.git (read-only)
Package Base: mailcrypt
Description: Emacs interface to PGP and GnuPG
Upstream URL: http://mailcrypt.sourceforge.net/
Licenses: GPL
Submitter: sergej
Maintainer: haawda
Last Packager: haawda
Votes: 8
Popularity: 0.000000
First Submitted: 2009-07-16 13:59
Last Updated: 2016-06-08 18:57

Latest Comments

haawda commented on 2014-08-30 10:29

Why don't you have timer.el? emacs from [extra] has such a file.

shackra commented on 2014-08-30 01:03

well, there is a different error:

aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'
checking for a BSD-compatible install... /usr/bin/install -c
checking for install-info... /usr/bin/install-info
checking for basename... /usr/bin/basename
checking for emacs... 24.3.1 (term:0.96)
checking for timer.el...no. I will install it for you.
configure: creating ./config.status
config.status: creating Makefile
config.status: WARNING: 'Makefile.in' seems to ignore the --datarootdir setting
config.status: creating tests/Makefile
config.status: creating tests/remailer/Makefile
cp FSF-timer.el timer.el
24.3.1 (term:0.96) -batch -l ./load-path.hack \
-f batch-byte-compile timer.el
/bin/sh: -c: línea 0: error sintáctico cerca del elemento inesperado `term:0.96'
/bin/sh: -c: línea 0: `24.3.1 (term:0.96) -batch -l ./load-path.hack \'
Makefile:70: recipe for target 'timer.elc' failed
make: *** [timer.elc] Error 1

haawda commented on 2014-08-29 22:35

Please try again with -5.

shackra commented on 2014-08-29 22:29

Nop. Still failing:

In toplevel form:
mc-gpg.el:105:1:Warning: !! The file uses old-style backquotes !!
This functionality has been obsolete for more than 10 years already
and will be removed soon. See (elisp)Backquote in the manual.

In mc-gpg-process-region:
mc-gpg.el:241:51:Warning: (lambda (x) ...) quoted with ' rather than with #'

In mc-gpg-encrypt-region:
mc-gpg.el:442:29:Warning: (lambda (x) ...) quoted with ' rather than with #'

In mc-gpg-fetch-key-parser:
mc-gpg.el:1304:19:Warning: Use `with-current-buffer' rather than
save-excursion+set-buffer
Wrote /tmp/mailcrypt/src/mailcrypt-3.5.9/mc-gpg.elc
emacs -batch -l ./load-path.hack \
-f batch-byte-compile expect.el

In toplevel form:
expect.el:28:1:Warning: cl package required at runtime
Wrote /tmp/mailcrypt/src/mailcrypt-3.5.9/expect.elc
emacs -batch -l ./load-path.hack \
-f batch-byte-compile mc-setversion.el
Wrote /tmp/mailcrypt/src/mailcrypt-3.5.9/mc-setversion.elc
makeinfo ./mailcrypt.texi
./mailcrypt.texi:11: warning: etiqueta indefinida: TITLE
/usr/bin/texi2dvi: texinfo.tex appears to be broken.
This may be due to the environment variable TEX set to something
other than (plain) tex, a corrupt texinfo.tex file, or
to tex itself simply not working.
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Parabola GNU/Linux-libre)
restricted \write18 enabled.
entering extended mode
(./txiversion.tex
! I can't find file `texinfo.tex'.
l.1 \input texinfo.tex
@bye
(Press Enter to retry, or Control-D to exit)
Please type another input file name:
! Emergency stop.
l.1 \input texinfo.tex
@bye
No pages of output.
Transcript written on txiversion.log.
/usr/bin/texi2dvi: quitting.

haawda commented on 2014-08-29 22:25

Oops, I thought I already fixed that.

texlive-core should me enough.

shackra commented on 2014-08-29 18:52

Yup, some tex packages are missing...

aaronfischer commented on 2014-07-07 08:33

Some tex-package missing as a dependency. Can;t figure out which one.
core/texinfo is installed.

makeinfo ./mailcrypt.texi
./mailcrypt.texi:11: warning: undefined flag: TITLE
This is TeX, Version 3.1415926 (TeX Live 2013/Arch Linux)
(./mailcrypt.texi
! I can't find file `texinfo'.
l.1 \input texinfo
@c -*-Texinfo-*-
(Press Enter to retry, or Control-D to exit)
Please type another input file name:
! Emergency stop.
l.1 \input texinfo
@c -*-Texinfo-*-
No pages of output.

haawda commented on 2010-09-17 17:22

This file and some more documentation files were added.

ecraven commented on 2010-09-17 14:24

please add mc-pgp6.el to the list of files in the PKGBUILD