Package Details: make-3.81 3.81-2

Git Clone URL: https://aur.archlinux.org/make-3.81.git (read-only)
Package Base: make-3.81
Description: GNU make utility to maintain groups of programs (3.81 version)
Upstream URL: http://www.gnu.org/software/make
Licenses: GPL
Submitter: ilikenwf
Maintainer: ItachiSan
Last Packager: ItachiSan
Votes: 13
Popularity: 0.000000
First Submitted: 2012-04-07 01:50
Last Updated: 2018-06-21 14:41

Latest Comments

ItachiSan commented on 2018-10-02 17:31

@rjn you need to import the GPG key, else the sources check will fail.

I am pretty sure it is explained in the ArchWiki.

rjn commented on 2018-09-22 15:23

I'm getting the following:

==> Validating source files with sha256sums... make-3.81.tar.gz ... Passed make-3.81.tar.gz.sig ... Skipped make-glibc_alloc_fix.patch ... Passed perl-use_safe_inclusion.patch ... Passed ==> Verifying source file signatures with gpg... make-3.81.tar.gz ... FAILED (unknown public key 96B047156338B6D4) ==> ERROR: One or more PGP signatures could not be verified! ==> ERROR: Makepkg was unable to build make-3.81.

ItachiSan commented on 2018-06-21 14:41

@BangL: I fixed the PKGBUILD quite a bit, now it should work without issues.

BangL commented on 2018-05-29 19:44

Currently, this package does not build on Manjaro, and throws the error msg "undefined reference to `__alloca'", in the file "glob.c". I don't know about Arch, but i guess it's the same.

This seems to be an incompatibility with a newer version of glibc.

To fix this, i copied this patch file: https://github.com/InuSasha/LibreELEC.tv/blob/97733bb439f16dd833bf80f159018d81f8d286e0/packages/devel/make/patches/make-glibc_alloc_fix.patch to "/tmp/make-glibc_alloc_fix.patch". Then i edited the PKGBUILD of this package, by adding "patch -p1 -i /tmp/make-glibc_alloc_fix.patch" after the line "cd ${srcdir}/${pkgname}" in the "build()" function.

ItachiSan commented on 2014-02-16 21:35

@aitjcize, I find no reason to update this...
You can easily do a 3.82 version of this package just editing a few lines ;)

aitjcize commented on 2014-02-16 14:44

can you change the package name to make3 and update the version to 3.82?

ItachiSan commented on 2013-11-24 13:32

@xavery, it won't clash as the binary file is 'make-3.81' and not 'make'.
I mean that if you want to use it, you should use from CLI
$ make-3.81
instead of
$ make

xavery commented on 2013-09-03 20:28

The PKGBUILD should also have provides=('make') and conflicts=('make') in order to avoid clashes with the main make package.

MreDD commented on 2012-05-29 05:11

may wanna make that change, it works this way.

pkgname=make-3.81
_pkgname=make
pkgver=3.81
pkgrel=1
pkgdesc="Old version for building AOSP - GNU make utility "
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/make"
license=('GPL')
groups=('base-devel')
depends=('glibc' 'sh')
install=$pkgname.install
source=(ftp://ftp.gnu.org/gnu/${_pkgname}/${pkgname}.tar.gz)

MreDD commented on 2012-05-28 09:09

edit your PKGBUILD

change:
source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}.tar.gz)
to:
source=(ftp://ftp.gnu.org/gnu/${pkgname}.tar.gz)