Package Details: manaplus-git 1.7.3.4.r21.g65d1cadca-1

Git Clone URL: https://aur.archlinux.org/manaplus-git.git (read-only)
Package Base: manaplus-git
Description: ManaPlus GIT version.
Upstream URL: http://manaplus.evolonline.org
Licenses: GPL2
Conflicts: manaplus
Submitter: dans
Maintainer: Trilby
Last Packager: Trilby
Votes: 15
Popularity: 0.000000
First Submitted: 2012-01-15 08:57
Last Updated: 2017-03-07 00:07

Latest Comments

Trilby commented on 2017-03-07 00:09

I've just re-adopted this as a physfs has been removed as a dependency upstream which avoids a bug present in the main repo version of this package.

I've also switched to sdl2 for this PKGBUILD.

I'll gladly hand this over to anyone else interested in maintaining it as once a post-physfs version is available in [community] I will use that again.

Trilby commented on 2017-01-02 14:18

While this likely still works, I no longer use this package and will not really keep an eye on it, thus I'm disowning it. Anyone can please feel free to pick it up.

I opted to maintain this package in the AUR when the manaplus package in the main repos was using the old client. The version in [community] has been 4144's client for some time, and it seems kept well up to date, so I just use the [community] package now.

Trilby commented on 2015-04-06 18:02

Thanks Tiedemann, I haven't been using this much lately, so I didn't notice the upstream change. I'll update a new PKGBUILD shortly.

Tiedemann commented on 2015-04-06 16:43

Noob with issues here ;)

I just get an error message about git not being able to read the repo.
Can't clone it with git clone either (I guess the PKGBUILD thingy does the same thing anyway).

Got this from their IRC channel:
<{41444d494e}> Tiedemann: for arch need update manaplus-git PKGBUILD
<{41444d494e}> need replace git:// to git+https://
<{41444d494e}> or even also in url replace gitorious.org to gitlab.com

So now my PKGBUILD looks like this:
source=("${_gitname}::git+https://gitlab.com/manaplus/manaplus.git")

The game works now :)

Trilby commented on 2014-05-28 20:05

I've just adopted this package and moved to the pacman 4.1 VCS package build. You may notice on the first update after this change that makepkg/pacman will report that the package is being downgraded. This is expected as the version numbers now follow the git commit while previously they used the datea YYYYMMDD format of the first submission to the AUR.

Trilby commented on 2014-05-18 21:14

Please update to the pacman/makepkg 4 format:

_gitname="manaplus"
pkgname="${_gitname}-git"
pkgver=0
pkgrel=1
pkgdesc="ManaPlus GIT version."
arch=('i686' 'x86_64')
url="http://manaplus.evolonline.org"
license=('GPL2')
depends=('libxml2' 'physfs' 'sdl_image' 'sdl_mixer' 'sdl_net' 'sdl_ttf' 'sdl_gfx' 'xsel' 'glu')
conflicts=('manaplus')
source=("${_gitname}::git://gitorious.org/manaplus/manaplus.git")
sha256sums=('SKIP')

pkgver() {
cd "${_gitname}"
git rev-list --count HEAD.$(git describe --always)
}

build() {
cd "${_gitname}"
autoreconf -i
./configure --prefix=/usr
make
}

package() {
cd "${_gitname}"
make DESTDIR="$pkgdir/" install
}