Package Details: markmywords-git d6f19f4-1

Git Clone URL: https://aur.archlinux.org/markmywords-git.git (read-only)
Package Base: markmywords-git
Description: A minimal markdown editor. It is currently under heavy development.
Upstream URL: https://github.com/voldyman/MarkMyWords
Licenses: None
Conflicts: markmywords
Provides: markmywords
Submitter: emersion
Maintainer: emersion
Last Packager: emersion
Votes: 6
Popularity: 0.742206
First Submitted: 2015-01-08 16:26
Last Updated: 2015-07-14 12:49

Latest Comments

starfry commented on 2016-02-03 15:34

Upstream fixed: https://github.com/voldyman/MarkMyWords/commit/c0573365a2601fdd2030c8db5b0fc9cd2baad7be

starfry commented on 2016-01-29 11:03

The upstream Git package contains a 64-bit binary.

It's located in the src as "deps/discount/mktags" and its presence breaks builds on other architectures such as i686, which the PKGBUILD supports.

But the source is also there. I worked around it by adding the below to the PKGBUILD in the build() function before "mkdir build":

(cd deps/discount; gcc mktags.c -o mktags)

Just in case anyone else hits this.

starfry commented on 2016-01-21 19:02

I don't know what I had wrong but I did manage to build it successfully, just thought I'd let you know.

emersion commented on 2016-01-02 00:30

Strange, works well for me. The vala package 'gtksourceview-3.0' is in gtksourceview3 (see https://www.archlinux.org/packages/extra/i686/gtksourceview3/files/).

starfry commented on 2015-12-31 13:01

Just trying to build this. I'm getting "package 'gtksourceview-3.0>=3.10' not found". I have gtksourceview3 installed. Is there another dependency missing that I need but am unaware of?

emersion commented on 2015-03-07 12:41

Hum, problem fixed ;-)

emersion commented on 2015-03-05 19:48

@MichaelTunnell No, I'm referring to the upload of the new package to AUR. I keep getting this error, don't know why.

MichaelTunnell commented on 2015-02-12 18:13

@emersion are you referring to the manual install and when you launch or when do you get this error? I haven't received any such error so far on the manual install.

emersion commented on 2015-02-11 17:50

@MichaelTunnell Looks like I can't update the package.

I get "Error - all files must have permissions of 644 or 755.", but all files have the correct permissions. Can you try please?

MichaelTunnell commented on 2015-02-11 17:15

@emersion I have tested the manual install as you requested and it seems to be working just fine, no obvious errors and the application launches successfully. :)

All comments