Package Details: mat 0.6.1-1

Git Clone URL: https://aur.archlinux.org/mat.git (read-only)
Package Base: mat
Description: Metadata anonymisation toolkit
Upstream URL: https://mat.boum.org
Licenses: GPL2
Submitter: npouillard
Maintainer: Francois_B
Last Packager: Francois_B
Votes: 33
Popularity: 2.310162
First Submitted: 2011-10-30 19:58
Last Updated: 2016-02-07 00:53

Latest Comments

maxweiss commented on 2017-04-07 15:43

To anybody looking for this package as I was, I just watched the command line errors that python was throwing when I tried to run it, and found that a few more packages are required. Install the optionals, and then also install the AUR packages 'hachoir-core' and 'hachoir-parser', and it should work.

FI_Mathematician commented on 2017-01-03 05:12

This tool sadly is completely broken, even getting mutagen and pthon-bloatware, it does not seem to want to work.

Sadly the dev is also on sick leave. From MAT's manpage
"Current status

The MAT maintenance and development is currently on hold, mostly for health reasons. I might go back to it at some point in the future.

The current version might have bugs, and doesn't work on Python3: Please avoid using it."

webdawg commented on 2016-04-03 19:47

python-pyexiftool does the same thing!

webdawg commented on 2016-02-07 01:04

So trying to get the python2 setup.py test to work....


pacman -Sv mutagen
sudo pacman -Sv python-mutagen
sudo pacman -Sv python-distutils-extra
yaourt python-pyexiftool
nano /home/bla/yaourt_temp
TMPDIR="/home/bla/yaourt_temp"

yaourt pyexiftool
yaourt python-pyexiftool

python-pyexiftool ends up screwing up....just going to skip this for now

webdawg commented on 2016-02-07 00:38

flagged out of date, 2 versions behind.....

https://git.torproject.org/user/jvoisin/mat.git

Francois_B commented on 2015-05-13 12:31

updated, thanks.

Guichu commented on 2015-05-13 10:24

Add python2-pillow to the dependencies,it is necessary for some files.

Francois_B commented on 2015-04-19 15:46

sha will be used for the next update :)

GI_Jack commented on 2015-04-18 19:25

>2015
>still using md5 check sums

suggestion: use sha256sums=(), or gpg signing.

Francois_B commented on 2013-12-28 22:47

Added. Thanks.

GI_Jack commented on 2013-12-28 22:25

needs python2-gobject

test0 commented on 2012-09-22 13:08

PKGBUILD for pdfrw: http://pastebin.com/1dgnZWS4 (thanks to http://forums.archlinux.fr/topic11552.html). Works just fine with PDF now.

npouillard commented on 2012-08-26 08:59

This package needs some love please adopt.

Distag commented on 2012-08-01 09:40

Are you sure that your package is correctly built? I know there is a problem somewhere.
Because python-pdfrw is implemented in python2-rst2pdf.
And I have got this error message: "Unable to import python-pdfrw: no PDf support" when I use mat.
Can you check your packet? please.

Distag commented on 2012-07-31 16:37

Yes, I know. There are just python library files to add.
But it would be good that somebody makes it, otherwise the soft don't work correctly.

npouillard commented on 2012-07-30 09:28

@Distag I don't see any release of pdfrw. Should we make a package out of the SVN repo?

Distag commented on 2012-07-29 17:01

Could you build the pdfrw packet, please.
http://code.google.com/p/pdfrw/

pigmonkey commented on 2012-06-13 16:30

Dependency `perl-exiftool' of `mat' does not exist.

Should it be perl-image-exiftool?

npouillard commented on 2012-06-07 14:55

mat-0.3.2-2 is uploaded.

@Distag: the build error that you refer to might due to the fact that python-distutils-extra use to be a python2 package and is now a python3 one.
I changed python-distutils-extra to python2-distutils-extra accordingly.

Distag commented on 2012-06-06 17:47

Badly built packet!

x33a commented on 2012-05-07 13:56

0.3.1 out

Anonymous comment on 2012-01-12 08:46

Updated PKGBUILD
https://pastee.org/423th