Package Details: mate-panel-git v1.25.3.r0.gb7f96b10-1

Git Clone URL: https://aur.archlinux.org/mate-panel-git.git (read-only, click to copy)
Package Base: mate-panel-git
Description: The MATE Panel
Upstream URL: https://mate-desktop.org
Licenses: GPL
Groups: mate
Conflicts: mate-panel, mate-panel-gtk3
Provides: mate-panel, mate-panel-gtk3
Submitter: hedgepigdaniel
Maintainer: hedgepigdaniel
Last Packager: hedgepigdaniel
Votes: 0
Popularity: 0.000000
First Submitted: 2019-08-24 04:21
Last Updated: 2021-07-14 10:13

Required by (45)

Sources (1)

Latest Comments

hedgepigdaniel commented on 2021-07-14 10:13

Thanks @Depau

I could not apply your patches with git, but I've manually recreated and pushed them.

Depau commented on 2021-07-13 19:37

You also need to conflict with mate-panel since files conflict. Also, replaces should instead be provides.

replaces is for repo packages so that they automatically replace an installed package that is obsolete. provides is for packages that provide functionality of another package and should be considered a success when pulling in the other package as a dependency. The latter is the case of this package.

From c06c4b2929b236c418321261b9cefea499abf08d Mon Sep 17 00:00:00 2001
From: Davide Depau <davide@depau.eu>
Date: Tue, 13 Jul 2021 21:35:12 +0200
Subject: [PATCH] Conflict with mate-panel package

---
 .SRCINFO | 3 ++-
 PKGBUILD | 4 ++--
 2 files changed, 4 insertions(+), 3 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index 4cfce67..30636c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,9 +20,10 @@ pkgbase = mate-panel-git
    depends = mate-menus
    depends = mate-desktop
    depends = gtk-layer-shell
+   provides = mate-panel-gtk3
    provides = mate-panel
    conflicts = mate-panel-gtk3
-   replaces = mate-panel-gtk3
+   conflicts = mate-panel
    source = git+https://github.com/mate-desktop/mate-panel
    sha256sums = SKIP

diff --git a/PKGBUILD b/PKGBUILD
index dd0a488..731a944 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,8 +17,8 @@ depends=('dbus-glib' 'libwnck3' 'libcanberra' 'libmateweather' 'libsm' 'mate-men
 makedepends=('mate-common' 'yelp-tools' 'intltool' 'itstool' 'gobject-introspection' 'gtk-layer-shell')
 source=("git+https://github.com/mate-desktop/mate-panel")
 groups=('mate')
-conflicts=('mate-panel-gtk3')
-replaces=('mate-panel-gtk3')
+conflicts=('mate-panel-gtk3' 'mate-panel')
+provides=('mate-panel-gtk3' 'mate-panel')

 prepare() {
   cd "$srcdir/$_pkgname"
-- 
2.32.0

Depau commented on 2021-07-13 19:33

Hi, this package is recently failing to build due to the fact that some stuff has been moved into submodules which are not being downloaded.

You can apply the following patch, git am < file.patch

From 786f68dfb6d434b62448bba564b95170a2ee2341 Mon Sep 17 00:00:00 2001
From: Davide Depau <davide@depau.eu>
Date: Tue, 13 Jul 2021 21:31:51 +0200
Subject: [PATCH] Download submodules on prepare

---
 .SRCINFO | 3 +--
 PKGBUILD | 8 ++++----
 2 files changed, 5 insertions(+), 6 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index ad574e5..4cfce67 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
 pkgbase = mate-panel-git
    pkgdesc = The MATE Panel
-   pkgver = v1.23.1.r13.g950caf8a
+   pkgver = v1.25.3.r0.gb7f96b10
    pkgrel = 1
    url = https://mate-desktop.org
    arch = x86_64
@@ -27,4 +27,3 @@ pkgbase = mate-panel-git
    sha256sums = SKIP

 pkgname = mate-panel-git
-
diff --git a/PKGBUILD b/PKGBUILD
index dcb7e13..dd0a488 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
 # Maintainer: Daniel Playfair Cal <Daniel.playfair.cal@gmail.com>
 # Contributor: Brad Fanella <cesura@archlinux.org>
 # Contributor: Martin Wimpress <code@flexion.org>
+# Contributor: Davide Depau <davide@depau.eu>

 pkgname=mate-panel-git
 _pkgname=mate-panel
 sha256sums=('SKIP')
-sha256sums=('SKIP')
 provides=(mate-panel)
-pkgver=v1.23.1.r13.g950caf8a
+pkgver=v1.25.3.r0.gb7f96b10
 pkgrel=1
 pkgdesc="The MATE Panel"
 url="https://mate-desktop.org"
@@ -19,10 +19,10 @@ source=("git+https://github.com/mate-desktop/mate-panel")
 groups=('mate')
 conflicts=('mate-panel-gtk3')
 replaces=('mate-panel-gtk3')
-sha256sums=('SKIP')

 prepare() {
-  cd "$srcdir"
+  cd "$srcdir/$_pkgname"
+  git submodule update --init --recursive
 }

 pkgver() {
-- 
2.32.0