Package Details: mathematica 12.0.0-1

Git Clone URL: https://aur.archlinux.org/mathematica.git (read-only)
Package Base: mathematica
Description: A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing.
Upstream URL: http://www.wolfram.com/mathematica/
Licenses: proprietary
Submitter: Feanor12
Maintainer: JP-Ellis
Last Packager: JP-Ellis
Votes: 61
Popularity: 0.591460
First Submitted: 2011-03-03 21:27
Last Updated: 2019-06-09 00:27

Dependencies (61)

Required by (1)

Sources (1)

Pinned Comments

JP-Ellis commented on 2019-04-24 05:41

Update to Mathematica 12.0.0

Summary of new features: https://wolfr.am/new-features-12

Please let me know if you encounter any issues.

Latest Comments

« First ‹ Previous ... 9 10 11 12 13 14 15 16 17 18 19 ... Next › Last »

someonerandom commented on 2016-04-24 12:28

If someone recently wants to build this package, keep away from gzip-1.7-1:

gzip: write error: Bad file descriptor
expr: syntax error
Critical Failure in CheckSpace_()
Unix/Installer/MathInstaller: line 3484: [: =: unary operator expected
Unix/Installer/MathInstaller: line 3488: [: =: unary operator expected
Unix/Installer/MathInstaller: line 3484: [: =: unary operator expected
Unix/Installer/MathInstaller: line 3488: [: =: unary operator expected

This is only fixed at git at the moment: http://git.savannah.gnu.org/cgit/gzip.git/commit/?id=3557cd57906915eb9c990b5f386e25c395592643

kjslag commented on 2016-04-22 01:35

@chrisbdaemon: Yes, they keep renaming their desktop files... :/

Also, the xdg-icon-resource errors from 10.3.1 are back. (It was temporarily fixed in 10.4.0.) Luckily, these errors appear to be harmless. I emailed Wolfram about it again.

chrisbdaemon commented on 2016-04-20 16:27

Has anyone had success installing 10.4.1? I changed the pkgver and the md5 hashsum and the installation fails. No real information on why either.

Update: Found the problem, wolfram-mathematica10.desktop is now wolfram-mathematica.desktop

doug commented on 2016-03-21 21:11

yes it works, we are using MathLM network license manager and have no problem activating

kjslag commented on 2016-03-19 19:34

I hope so. However, I haven't managed to successfully activate Mathematica 10.4 yet. Neither the online nor offline password generator have worked for me, and I'm still discussing with tech support. If someone confirms that 10.4 does indeed work on Arch, I'll update the package. You can test by changing the pkgver line near the top of the PKGBUILD, and then build using
makepkg --skipinteg

GLaDER commented on 2016-03-19 18:57

Is there an upcoming 10.4-package coming?

batarjal commented on 2016-03-12 02:53

That worked. Thanks for your help!

kjslag commented on 2016-03-10 20:04

To install a different version, change the pkgver line near the top of the PKGBUILD to the desired version, and build with
makepkg --skipinteg

batarjal commented on 2016-03-10 12:58

That's probably my issue - My installer's name is Mathematica_10.1.0_LINUX.sh. Is there a way to use your package with my installer? My university only has version 10.1 available at this point in time.

kjslag commented on 2016-03-10 05:28

It's correct to have the installer in the same directory as the PKGBUILD. What's the name of the installer? The PKGBUILD currently expects Mathematica_10.3.1_LINUX.sh.