Package Details: mathematica 12.0.0-1

Git Clone URL: https://aur.archlinux.org/mathematica.git (read-only)
Package Base: mathematica
Description: A computational software program used in scientific, engineering, and mathematical fields and other areas of technical computing.
Upstream URL: http://www.wolfram.com/mathematica/
Licenses: proprietary
Submitter: Feanor12
Maintainer: JP-Ellis
Last Packager: JP-Ellis
Votes: 61
Popularity: 1.201555
First Submitted: 2011-03-03 21:27
Last Updated: 2019-06-09 00:27

Dependencies (61)

Required by (1)

Sources (1)

Pinned Comments

JP-Ellis commented on 2019-04-24 05:41

Update to Mathematica 12.0.0

Summary of new features: https://wolfr.am/new-features-12

Please let me know if you encounter any issues.

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

JP-Ellis commented on 2018-04-11 05:06

@qft I have added openmp are a required dependency (instead of just an optional one). Thanks for the feedback.

Note that I will not be incrementing the release number as this is such a minor change (and openmp was already optional). If there are libraries which are required, please let me know.

qft commented on 2018-04-11 04:50

openmp should be a dependency of the latest version, otherwise mathematica complains about missing libiomp5.so and cannot start.

JP-Ellis commented on 2018-04-10 23:33

@jumper149 I have made a new release of 11.3.0, please give it a go and let me know if you have any issue with it. (The reason you couldn't find the libraries is that they are located in /opt/Mathematica/SystemFiles/Libraries/Linux-x86-64/)

jumper149 commented on 2018-04-10 13:23

I uninstalled Mathematica 11.2 with instructions from http://support.wolfram.com/kb/12473. Before it was installed without pacman. I lately got the error: /opt/Mathematica/SystemFiles/FrontEnd/Binaries/Linux-x86-64/Mathematica: symbol lookup error: /usr/lib/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var

Then i installed Mathematica 11.3 with this aur package. The fix @JP-Ellis is not possible because the following files are NOT in /opt/Mathematica/SystemFiles/FrontEnd/Binaries/Linux-x86-64/:

freetype.so.6, freetype.so and libz.so

so i cant remove them.

The installation seems fine I think.

/lib/libfontconfig.so.1 exists.

what can i do now i still get the fontconfig error.

JP-Ellis commented on 2018-03-26 06:25

As pointed out by wjhandley, a recent update broke aspects of Mathematica handling fonts. At this stage, the easiest is to just remove freetype.so.6, freetype.so and libz.so so that Mathematica falls back to the system libraries.

I am currently testing a new release of 11.3.0 which removes certain libraries already provided by the system. Although everything works fine for me so far, I suspect this may break things for some users until they install the necessary optional dependencies. I will be releasing the next release in the next day or so.

wjhandley commented on 2018-03-25 16:23

If you get an error like:

/opt/Mathematica/SystemFiles/FrontEnd/Binaries/Linux-x86-64/Mathematica: symbol lookup error: /lib/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var

then just remove or rename the mathematica freetype.so.6 and libz.so libraries in the directory ${TopDirectory}/SystemFiles/Libraries/Linux-x86-64

(source https://bugs.archlinux.org/task/57948 )

JP-Ellis commented on 2018-03-15 04:26

Update to Mathematica 11.3.0

Summary of new features: https://wolfr.am/new-features-11-3

Release 2 The second release of 11.3.0 removes various libraries which are automatically included in Mathematica so that Mathematica falls back on the system version. This was done in order to address an incompatibility in a recent system library update. I have been using this release for a while with no issue, but as usual let me know if any issue comes up.

In particular, portaudio may be required (though is not necessary is you only run Mathematica from the command line)

Release 3 Update reflects the new release of 11.3.0 by Wolfram. I could not find release notes (probably a minor bug fix release).

eisterman commented on 2018-03-14 08:53

I've fixed the PKGBUILD for the 11.3

https://pastebin.com/PcwuXDw8

Changelog:

  • Update pkgver

  • Updated hardcoded name wolframscript_1.2.0-22_amd64.deb to wolframscript_1.2.0-36_amd64.deb

  • Updated data.tar.xz to data.tar.gz (file inside wolframscript_1.2.0-36_amd64.deb)

  • Fixed bug on a mkdir that interrupted the compilation if the folder ${srcdir}/WolframScript already existed (line 143 old version, missing -p argument)

PKGBUILD already tested, but only on a single PC x86_64.

JP-Ellis commented on 2018-03-14 04:04

I'm aware that 11.3 of Mathematica has been released; unfortunately, my licence so far does not allow me to download 11.3. As soon as I am able to get my hand on 11.3, I will update this package. Sorry for the delay.

JP-Ellis commented on 2017-09-30 11:07

@Excaliber You need to have the PKGBUILD and the Mathematica installer in the same directory (a symlink works too).