Package Details: mathgl 8.0.1-1

Git Clone URL: https://aur.archlinux.org/mathgl.git (read-only, click to copy)
Package Base: mathgl
Description: A library for making high-quality scientific graphics
Upstream URL: http://mathgl.sourceforge.net
Keywords: graphics plotting science scientific visualization
Licenses: GPL3
Submitter: alfagalileo
Maintainer: Mr.Smith1974
Last Packager: Mr.Smith1974
Votes: 7
Popularity: 0.020906
First Submitted: 2015-08-30 03:35 (UTC)
Last Updated: 2023-10-31 05:44 (UTC)

Latest Comments

Mr.Smith1974 commented on 2023-10-15 06:13 (UTC)

8.0 Released 1 January 2022

adsun commented on 2019-07-30 02:45 (UTC)

This also needs glu added to the depends array, otherwise the build fails in a clean chroot.

alfagalileo commented on 2017-06-19 17:48 (UTC) (edited on 2019-03-14 15:17 (UTC) by alfagalileo)

Thank you evotopid, I've done the change.

evotopid commented on 2017-06-19 13:33 (UTC)

Version 2.4-1 of the package fails with a 404 error for me. The URL should be just "http://downloads.sourceforge.net/project/mathgl/mathgl/2.4/mathgl-2.4.tar.gz" (no "mathgl%20" before "2.4" anymore, they seem to have changed the folder structure with the most recent release).

evotopid commented on 2016-10-09 18:53 (UTC) (edited on 2016-10-18 12:00 (UTC) by evotopid)

For me building the package fails with HDF5 enabled, disabling it fixes the issue for me. (However this might not be an acceptable option for everyone). I guess it's just an issue of CMake not finding the library but I'm not exactly sure how to troubleshoot and fix the issue. **Edit: ** By installing hdf5-cpp-fortran instead of hdf5 I was able to compile with hdf support enabled. However I wasn't able to do the build without octave installed.

DominarXVI commented on 2016-01-27 15:13 (UTC)

Would not build without gsl, wxgtk, texlive-plainextra packages installed.

Ferruck commented on 2015-11-26 14:30 (UTC)

Please add Qt as a dependency or disable it in the PKGBUILD. Also, there seems to be a problem with TeX in the moment, it fails with [ 26%] Generating mgl_en.pdf cd /tmp/yaourt-tmp-philipp/aur-mathgl/src/mathgl-2.3.3/build/texinfo && /usr/bin/texi2pdf /tmp/yaourt-tmp-philipp/aur-mathgl/src/mathgl-2.3.3/texinfo/mgl_en.texi /usr/bin/texi2dvi: texinfo.tex appears to be broken. This may be due to the environment variable TEX set to something other than (plain) tex, a corrupt texinfo.tex file, or to tex itself simply not working. This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015/Arch Linux) (preloaded format=etex) restricted \write18 enabled. entering extended mode (./txiversion.tex ! I can't find file `texinfo.tex'. l.1 \input texinfo.tex @bye (Press Enter to retry, or Control-D to exit) Please type another input file name: ! Emergency stop. l.1 \input texinfo.tex @bye No pages of output. Transcript written on txiversion.log. /usr/bin/texi2dvi: quitting. Removing all documentation in the PKGBUILD resolves the problem. Thanks.

alfagalileo commented on 2015-09-02 23:58 (UTC)

Ok, done¡

Glaciuse commented on 2015-09-01 19:33 (UTC)

Please add freeglut and python2-numpy to dependencies. Without them building fails.