Package Details: mattermost-desktop 4.6.1-1

Git Clone URL: https://aur.archlinux.org/mattermost-desktop.git (read-only, click to copy)
Package Base: mattermost-desktop
Description: Mattermost Desktop application for Linux
Upstream URL: https://github.com/mattermost/desktop
Keywords: chat mattermost messenger networking slack
Licenses: Apache
Submitter: nineinchnick
Maintainer: caleb (wget)
Last Packager: caleb
Votes: 56
Popularity: 0.26
First Submitted: 2016-04-02 09:08
Last Updated: 2020-10-26 19:35

Dependencies (4)

Required by (0)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

caleb commented on 2020-06-01 07:10

@Severus Did you rebuild this package from scratch or just swap out you system's Electron?

Severus commented on 2020-06-01 07:01

the new version of electron is 9. But the package will crash if clicking any menu on File/View/... Changing electron to 7 is fine, seem that electron 9 wants to access dri but sandbox didnot allow

caleb commented on 2020-04-01 17:22

Sorry @TheGOliath and @tinux, I overlooked committing that change. The checksupm is correct, I just didn't pass along the right sh source file to go with it. Should be fixed now.

TheGoliath commented on 2020-04-01 17:15

mattermost-desktop.sh validity check failed

tinux commented on 2020-04-01 16:22

This packages only depends on electron, so mattermost-desktop.sh should probably not use electron6. Also, just electron works (for me).

EDIT: Incidentally, with this change also the checksum is correct now...

tinux commented on 2020-03-24 17:54

This works:

diff --git a/PKGBUILD b/PKGBUILD
index 6a484e5..699901e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
 # Contributor: Bruno Pagani <archange at archlinux dot org>

 pkgname=mattermost-desktop
-pkgver=4.3.2
+pkgver=4.4.0
 _electronMajorVersion=5
 pkgrel=1
 pkgdesc="Mattermost Desktop application for Linux"
@@ -15,12 +15,12 @@ depends=("electron${_electronMajorVersion}")
 makedepends=('npm' 'git' 'jq')
 #optdepends=('hunspell: spell checking')
 source=(
-    "${pkgname}-${pkgver}.tar.gz"::"${url}/archive/${pkgver}.tar.gz"
+    "${pkgname}-${pkgver}.tar.gz"::"${url}/archive/v${pkgver}.tar.gz"
     "${pkgname}.sh"
     "${pkgname/-/.}"
 )
 sha512sums=(
-    '40e871e0699b1e0ba7670024a368498d7477b5716ff3523ab04bb9c1567bb577cfc220071f6d0228ec2b1fdfe4caeaeba859fe47faf47c76e8f0dd135ef3cf78'
+    '7f4d72fe1b90fe17796c1e9eb2c5ff9bf3d3c7ff855585f9f20c1997317eb805b917f3b2a58e6add67668e60a542cb5e3be6202a30af4ce495184335e2b94b3e'
     '717a463d47cee1e70f210a78c6d72f64e62de36921b5805888ec48ade0cd037a250567c677b1a39243af82144d556cb708d8d79eb0b13499e75d3dc4bf533d98'
     'b8f24df883b71df4177155246fd5858ad785f75be4f7dfc674380674b48a45342b1f5ee217a20708f74ed8d2119d837bae4a3fd48d1b62d60d55644e36411266'
 )

noraj commented on 2020-03-17 17:55

This should be just a version bump to 4.4.0

caleb commented on 2020-03-13 16:39

Hey @wget would you like me to help maintain this too? Besides already helping you with mattermost itself I have some electron packaging experience. (e.g. ezra-project and zettlr-git)

wget commented on 2019-12-02 15:35

Package updated with latest upstream version.

I'm now relying on the system electron package, I removed a few unneeded files from electron.

I prepared the work to rely on system hunspell dictionaries. I hope to upstream that work soon upstream.

@dreieck I corrected the issue and the build process doesn't require an internet connection during packaging anymore. Only the prepare() step does.

wget commented on 2019-10-19 11:30

Package updated with latest upstream version. Cast y̶o̶u̶r̶ ̶v̶o̶t̶e̶s̶ your comments :)