Package Details: mattermost-desktop 4.6.1-1

Git Clone URL: https://aur.archlinux.org/mattermost-desktop.git (read-only, click to copy)
Package Base: mattermost-desktop
Description: Mattermost Desktop application for Linux
Upstream URL: https://github.com/mattermost/desktop
Keywords: chat mattermost messenger networking slack
Licenses: Apache
Submitter: nineinchnick
Maintainer: caleb (wget)
Last Packager: caleb
Votes: 56
Popularity: 0.26
First Submitted: 2016-04-02 09:08
Last Updated: 2020-10-26 19:35

Dependencies (4)

Required by (0)

Sources (3)

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10

nylocx commented on 2016-04-14 11:43

For me this currently fails to build even after installing npm and gendesk with this error
stream.js:74
throw er; // Unhandled stream error in pipe.
and
Error: ./src/~/electron-connect/lib/client.js
Module not found: Error: Cannot resolve module 'remote'

It seems to be an upstream bug:
https://github.com/mattermost/desktop/commit/cc2d65c7416ac6443a9402ffdd9e845ae4ac54e5

If anyone is interested, here is my updated PKGBUILD patch with the upstream fix backported:
http://paste.pound-python.org/show/8XPrzwpfoOjAX8DJsz74/

giniu commented on 2016-04-07 14:01

Also community/gendesk and community/npm are needed for build - they should be in "makedepends" array, not "builddepends". I highly recommend running namcap (https://wiki.archlinux.org/index.php/namcap) on your PKGBUILD and resulting package.

Anonymous comment on 2016-04-03 12:07

Needs extra/gconf to run.