Package Details: mattermost 4.0.1-1

Git Clone URL: https://aur.archlinux.org/mattermost.git (read-only)
Package Base: mattermost
Description: Open source Slack-alternative in Golang and React
Upstream URL: http://mattermost.org
Licenses: MIT
Submitter: mtorromeo
Maintainer: mtorromeo (wget)
Last Packager: mtorromeo
Votes: 18
Popularity: 1.753300
First Submitted: 2015-08-24 15:14
Last Updated: 2017-07-19 16:36

Latest Comments

mtorromeo commented on 2017-07-19 16:42

Should be fixed

frederik commented on 2017-07-19 14:37

@torromeo I have an issue with 4.0.0. The web frontend is not available. This fix works: https://github.com/mattermost/platform/issues/6956#issuecomment-316374589

kbeckmann commented on 2017-07-11 14:18

Seems this package also depends on npm. Solved it by installing it manually.


make[1]: Entering directory '/home/docker/.cache/pacaur/mattermost/src/platform-3.10.0/webapp'
Getting dependencies using yarn
yarn install --pure-lockfile --mutex file:/tmp/.yarn-mutex
yarn install v0.27.5
[1/4] Resolving packages...
[2/4] Fetching packages...
warning fsevents@1.1.1: The platform "linux" is incompatible with this module.
info "fsevents@1.1.1" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
[4/4] Building fresh packages...
error /home/docker/.cache/pacaur/mattermost/src/platform-3.10.0/webapp/node_modules/mattermost-redux: Command failed.
Exit code: 127
Command: sh
Arguments: -c npm run build
Directory: /home/docker/.cache/pacaur/mattermost/src/platform-3.10.0/webapp/node_modules/mattermost-redux
Output:
sh: npm: command not found

kaptoxic commented on 2017-05-16 21:59

Moreover, there are some warnings about the package:
==> Checking for packaging issue...
==> WARNING: Package contains reference to $srcdir

(Perhaps this is related to the previously raised issue.)

kaptoxic commented on 2017-05-16 03:02

I am getting an error (stated below) when running
$ /usr/share/webapps/mattermost/bin/platform user password test test
or
$ sudo -u mattermost /usr/share/webapps/mattermost/bin/platform user password test test
Does this mean this is an issue with the way mattermost is built in this package or something to report upstream?

The error:
panic: runtime error: invalid memory address or nil pointer dereference
[signal SIGSEGV: segmentation violation code=0x1 addr=0x0 pc=0xb6c168]

goroutine 1 [running]:
main.getUserFromUserArg(0x7ffd51ac6d47, 0x14, 0x0)
/tmp/yaourt-tmp-user/aur-mattermost/src/src/github.com/mattermost/platform/cmd/platform/userargs.go:21 +0x28
main.resetUserPasswordCmdF(0x10c8c40, 0xc4200d3240, 0x2, 0x2, 0x0, 0x0)
/tmp/yaourt-tmp-user/aur-mattermost/src/src/github.com/mattermost/platform/cmd/platform/user.go:274 +0xea
github.com/mattermost/platform/vendor/github.com/spf13/cobra.(*Command).execute(0x10c8c40, 0xc4200d2f80, 0x2, 0x2, 0x10c8c40, 0xc4200d2f80)
/tmp/yaourt-tmp-user/aur-mattermost/src/src/github.com/mattermost/platform/vendor/github.com/spf13/cobra/command.go:632 +0x3ef
github.com/mattermost/platform/vendor/github.com/spf13/cobra.(*Command).ExecuteC(0xc420096900, 0x0, 0x0, 0x0)
/tmp/yaourt-tmp-user/aur-mattermost/src/src/github.com/mattermost/platform/vendor/github.com/spf13/cobra/command.go:722 +0x339
github.com/mattermost/platform/vendor/github.com/spf13/cobra.(*Command).Execute(0xc420096900, 0xc4204740f0, 0xb)
/tmp/yaourt-tmp-user/aur-mattermost/src/src/github.com/mattermost/platform/vendor/github.com/spf13/cobra/command.go:681 +0x2b
main.main()
/tmp/yaourt-tmp-user/aur-mattermost/src/src/github.com/mattermost/platform/cmd/platform/mattermost.go:50 +0x4b2

kaptoxic commented on 2017-05-16 03:00

@basil you probably did not run the mysql server properly

basil commented on 2017-02-26 15:14

[CRIT] Failed to ping DB err:dial unix /run/mysqld/mysqld.sock: connect: no such file or directory

gabx commented on 2016-10-28 10:40

on 2016-10-26, package build fine IF you use git master branch and not the 3.4.0

gabx commented on 2016-08-26 08:37

Build failed too with the following error:

WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@1.0.14
npm WARN extract-text-webpack-plugin@1.0.1 requires a peer of webpack@^1.9.11 but none was installed.
npm WARN mocha-webpack@0.4.0 requires a peer of webpack@^1.12.13 but none was installed.
npm ERR! Linux 4.7.1-1-hortensia
npm ERR! argv "/usr/bin/node" "/usr/bin/npm" "install"
npm ERR! node v6.4.0
npm ERR! npm v3.10.6
npm ERR! code ELIFECYCLE

npm ERR! node-sass@3.8.0 postinstall: `node scripts/build.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-sass@3.8.0 postinstall script 'node scripts/build.js'.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the node-sass package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node scripts/build.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs node-sass
npm ERR! Or if that isn't available, you can get their info via:
npm ERR! npm owner ls node-sass

serialoverflow commented on 2016-08-10 22:48

Fails building for me, too, although with a different message:
https://bpaste.net/show/101810ee6f9b

This issue was fixed just 3 days ago on git but maybe you can patch it:
https://github.com/mattermost/platform/commit/5e2b4d1282dc374b54ca2c77fbf84c6533ce8519

All comments