Package Details: maubot 0.4.2-1

Git Clone URL: https://aur.archlinux.org/maubot.git (read-only, click to copy)
Package Base: maubot
Description: A plugin-based Matrix bot system
Upstream URL: https://github.com/maubot/maubot
Licenses: AGPL3
Submitter: noobping
Maintainer: jkhsjdhjs (noobping)
Last Packager: jkhsjdhjs
Votes: 1
Popularity: 0.000006
First Submitted: 2022-10-14 20:01 (UTC)
Last Updated: 2024-03-01 02:17 (UTC)

Latest Comments

1 2 Next › Last »

noobping commented on 2023-12-21 07:27 (UTC)

Thank you @jkhsjdhjs ☺

jkhsjdhjs commented on 2023-12-20 21:13 (UTC)

@noobping: No worries, private life always has priority. I adopted this package and added you as co-maintainer in case you want to maintain this package again at some point.

noobping commented on 2023-12-20 07:08 (UTC) (edited on 2023-12-20 07:12 (UTC) by noobping)

I am sorry @jkhsjdhjs and @MarsSeed. It is a busy and stressful time at the moment. So, I didn't have the time to test the update. @anyone Feel free to take ownership.

jkhsjdhjs commented on 2023-12-20 00:55 (UTC)

This package has now been flagged out of date for nearly 2 months, are you still active on here @noobping?

noobping commented on 2023-02-02 17:55 (UTC)

@jkhsjdhjs Thanks for the comment. I removed it.

jkhsjdhjs commented on 2023-02-02 17:18 (UTC)

The python-aiohttp task has been closed, so the workaround can be removed here.

noobping commented on 2022-11-11 10:36 (UTC)

@jahway603 I added the workaround to the install file. So you can update or reinstall maubot.

jkhsjdhjs commented on 2022-11-10 23:03 (UTC) (edited on 2022-11-10 23:03 (UTC) by jkhsjdhjs)

@jahway603 That's an issue with the python-aiohttp package, that this package depends on: https://bugs.archlinux.org/task/76326
The problem is that aiohttp depends on charset-normalizer<3, but the arch repos currently have 3.0.0. Until this is fixed, you can temporarily work around this by editing /usr/lib/python3.10/site-packages/aiohttp-3.8.3.dist-info/METADATA and removing <3.0, from the line

Requires-Dist: charset-normalizer (<3.0,>=2.0)

jahway603 commented on 2022-11-10 21:24 (UTC)

@jkhsjdhjs @noobping This package built, but mbc will not work. Please see the gist: https://gist.github.com/jahway603/1067d05c3d6e6fcf3b4f1ba3f63fe1a7 Unsure if this is an issue with this package or with maubot itself as I can run maubot from other Linux distros.

jahway603 commented on 2022-11-09 14:24 (UTC)

@jkhsjdhjs @noobping I resolved it. Thank you both.