Package Details: maubot 0.4.1-1

Git Clone URL: (read-only, click to copy)
Package Base: maubot
Description: A plugin-based Matrix bot system
Upstream URL:
Licenses: AGPLv3
Submitter: noobping
Maintainer: noobping
Last Packager: noobping
Votes: 1
Popularity: 0.001199
First Submitted: 2022-10-14 20:01 (UTC)
Last Updated: 2023-04-02 12:11 (UTC)

Latest Comments

1 2 Next › Last »

noobping commented on 2023-02-02 17:55 (UTC)

@jkhsjdhjs Thanks for the comment. I removed it.

jkhsjdhjs commented on 2023-02-02 17:18 (UTC)

The python-aiohttp task has been closed, so the workaround can be removed here.

noobping commented on 2022-11-11 10:36 (UTC)

@jahway603 I added the workaround to the install file. So you can update or reinstall maubot.

jkhsjdhjs commented on 2022-11-10 23:03 (UTC) (edited on 2022-11-10 23:03 (UTC) by jkhsjdhjs)

@jahway603 That's an issue with the python-aiohttp package, that this package depends on:
The problem is that aiohttp depends on charset-normalizer<3, but the arch repos currently have 3.0.0. Until this is fixed, you can temporarily work around this by editing /usr/lib/python3.10/site-packages/aiohttp-3.8.3.dist-info/METADATA and removing <3.0, from the line

Requires-Dist: charset-normalizer (<3.0,>=2.0)

jahway603 commented on 2022-11-10 21:24 (UTC)

@jkhsjdhjs @noobping This package built, but mbc will not work. Please see the gist: Unsure if this is an issue with this package or with maubot itself as I can run maubot from other Linux distros.

jahway603 commented on 2022-11-09 14:24 (UTC)

@jkhsjdhjs @noobping I resolved it. Thank you both.

jkhsjdhjs commented on 2022-11-08 18:47 (UTC)

@jahway603 That only shows that you have nodejs-lts-gallium installed, but that doesn't seem to be the nodejs version that is actually used. Can you check again with node -v?

@noobping I don't think adding nodejs as a dependency would change anything, as yarn (which is a make dependency) already depends on nodejs.

noobping commented on 2022-11-08 18:38 (UTC) (edited on 2022-11-09 13:07 (UTC) by noobping)

@jahway603 I see that you have a different nodejs (I have nodejs 19.0.1-1). Does this Dockerfile work for you? Also, please use something like pastebin for your logs.

~I could also add nodejs as a dependency...~

jkhsjdhjs commented on 2022-11-07 15:44 (UTC)

@jahway603 Your version of nodejs is outdated.