Package Details: maynard-git r123.b23c2a8-2

Git Clone URL: https://aur.archlinux.org/maynard-git.git (read-only)
Package Base: maynard-git
Description: Lightweight desktop environment based on Weston compositor for use with Wayland
Upstream URL: https://github.com/raspberrypi/maynard
Licenses: GPL, custom:MIT
Provides: maynard
Submitter: alive4ever
Maintainer: alive4ever
Last Packager: alive4ever
Votes: 3
Popularity: 0.001095
First Submitted: 2016-08-21 10:13
Last Updated: 2016-10-24 09:25

Latest Comments

alive4ever commented on 2016-10-16 15:29

@washctl, thanks for suggestion. Weston 1.12 is indeed a release with huge changes.

I'll leave it as is now and wait for upstream to fix building with weston 1.12.

Edit: Upstream has integrated the changes needed to build with weston 1.12, so the issue with weston 1.12 is fixed.

waschtl commented on 2016-10-15 21:12

As of commit a191e5c0b9593dfa203cbe83d43ac2699e51be6c on June 14, maynard cannot be compiled against weston 1.12.0 from September 20. I filed a bug upstream: https://github.com/raspberrypi/maynard/issues/47

I propose that the dependency on weston be changed to weston<1.12.

alive4ever commented on 2016-08-25 23:11

Currently, there is no easy way to add your own custom launchers, see [GH #7](https://github.com/raspberrypi/maynard/issues/7)

Until maynard upstream adds support for preferences, you can edit /usr/share/glib-2.0/schemas/org.raspberrypi.maynard.gschema.xml and recompiling glib schemas

# glib-compile-schemas /usr/share/glib-2.0/schemas

You can specify any application desktop launcher (*.desktop files), located on /usr/share/applications.

TrialnError commented on 2016-08-25 12:54

Thanks for those adjustments (Well if someone wants to nitpick he could point out, that the md5 function is also obsolete if check_install is removed ;) )

I have a more general question, as the official doc is kinda shallow.
Upon starting maynard, I have only the LO starter in the bar. But it is apparantly not set from my launchers defined in the weston.ini.
How to set launchers (or are they fixed in the sources)?
And the application menu (appearing after clicking those 4 dots), where does it get the entries? Because for me it is empty too.

alive4ever commented on 2016-08-22 22:47

I removed checkinstall() from maynard launch script to silence makepkg warning since makepkg doesn't forget to `make install`. The warning should be gone by now.

TrialnError commented on 2016-08-22 10:18

There is a reference to the $srcdir in the shell skript (see makepkg warning about this), where it crudely checks for missing make install instruction (ABS_BUILDDIR).
Such references should normally be avoided and I would suggest to remove this complete check-install function, as it cannot happen with the generated package.

alive4ever commented on 2016-08-22 03:47

Added intltool as build dependency.
Added gnome-menus and gnome-desktop as runtime dependencies.

Let's see if there is any issue.

TrialnError commented on 2016-08-21 21:11

Shouldn't be gnome-desktop and gnome-menus added as a dep?
Without those installed autogen failed for me as of not met requirements.

Additionally intltool seems to be needed as makedep, as without it, autogen also failed for me.