Package Details: mcomix-gtk3-git r1961.9ba2f5b-1

Git Clone URL: https://aur.archlinux.org/mcomix-gtk3-git.git (read-only, click to copy)
Package Base: mcomix-gtk3-git
Description: A comic book reader. Forked from MComix and ported to GTK3.
Upstream URL: https://github.com/multiSnow/mcomix3
Licenses: GPL
Conflicts: mcomix, mcomix-git
Provides: mcomix
Submitter: ilikenwf
Maintainer: jusw85
Last Packager: jusw85
Votes: 10
Popularity: 0.005966
First Submitted: 2018-01-28 21:50 (UTC)
Last Updated: 2021-02-27 14:09 (UTC)

Dependencies (11)

Required by (0)

Sources (1)

Latest Comments

jusw85 commented on 2021-02-27 14:11 (UTC)

@foxbox Updated

foxbox commented on 2021-02-27 13:00 (UTC)

In the repository's README its claims 'lha 7 to extract LHA archives.' can be used. Doesn't that mean the optional dependency lhasa\lha can be added?

rtentser commented on 2020-12-20 08:59 (UTC) (edited on 2020-12-20 08:59 (UTC) by rtentser)

Traceback (most recent call last): File "/usr/bin/mcomix", line 32, in <module> import mcomix.run ModuleNotFoundError: No module named 'mcomix'

Confirm.

facless_jack commented on 2020-12-14 12:00 (UTC)

Traceback (most recent call last): File "/usr/bin/mcomix", line 32, in <module> import mcomix.run ModuleNotFoundError: No module named 'mcomix'

crab2313 commented on 2020-12-03 04:17 (UTC)

The version of python should not be hardcoded as python3.8. Please update the PKGBUILD.

jusw85 commented on 2020-02-12 06:39 (UTC)

ERROR: Cannot find the git package needed to handle git sources.

git is missing from makedepends

Celti commented on 2020-01-20 22:30 (UTC)

As stated multiple times, git must be added to makedepends. Further, everything in the install file is already handled by existing pacman hooks.

FichteFoll commented on 2019-12-24 04:05 (UTC)

Still missing the git makedep.

adam900710 commented on 2019-11-15 08:22 (UTC)

Need to update PKGBUILD to adopt python3.8.

FichteFoll commented on 2019-06-04 11:27 (UTC)

This package is missing git in makedepends.

ilikenwf commented on 2019-05-15 13:54 (UTC)

@fettouhi @Singularity I'll try to look into it this weekend - we can either put it in this repo, or make a new "mcomix3-git" package.

Since I just finished hacking together the gtk3 branch on SF, the new contender may be a better option.

fettouhi commented on 2019-05-15 08:21 (UTC)

Yeah it would be nice if this could be switched to the active fork that @Singularity. But maybe it would appropriate to that in a different AUR? Since it is a fork of the Mcomix project.

Singularity commented on 2019-04-07 19:48 (UTC)

Hi. I found that there is an active fork working on GTK3 and Python3 support, having around ~200 commits more. https://pastebin.com/kc1h3M8V

ilikenwf commented on 2018-12-24 19:52 (UTC)

Thanks! Fixed.

svito commented on 2018-12-23 02:11 (UTC)

'python2-setuptools python2-gobject'

Those should be separate :)

ilikenwf commented on 2018-08-06 02:45 (UTC)

Fixed, also synced with master and replaced with my fork instead of a patch.

Kurobac commented on 2018-07-25 08:19 (UTC)

conflicts in PKGBUILD should be ("mcomix" "mcomix-git")