Package Details: mcpelauncher-git 20180405-1

Git Clone URL: https://aur.archlinux.org/mcpelauncher-git.git (read-only)
Package Base: mcpelauncher-git
Description: Launch MCPE on Linux!
Upstream URL: https://github.com/MCMrARM/mcpelauncher-linux
Keywords: mcpe mcpelauncher minecraft minecraft-linux
Licenses: BSD 2-clause + Other
Submitter: ErnyTech
Maintainer: nic96
Last Packager: nic96
Votes: 3
Popularity: 0.765614
First Submitted: 2018-01-03 15:21
Last Updated: 2018-04-06 15:59

Latest Comments

deusstultus commented on 2018-05-13 14:54

Missing makedepends libzip,wget,unzip used in upstream scripts run in prepare and git for source acquisition.

nicman23 commented on 2018-04-16 11:38

so, if you launch the game for the first time and you only see the background (something to go with gpu and chromium), run the game in gdb!

in the compiled (from makepkg) source run gdb ./mcpelauncher

and then in the resulting promt, type run

nic96 commented on 2018-04-11 14:22

@SuperGeniusZeb Just import the key using the following command.

$ gpg --keyserver hkp://pgp.mit.edu:80 --recv-key E23B7E70B467F0BF

Edit: You can also use a GUI tool like kgpg to import keys.

SuperGeniusZeb commented on 2018-04-11 14:06

When I try to install this package, I get an error when lib32-libevdev is being installed.

https://pastebin.com/amj8HN8S

nic96 commented on 2018-04-08 23:56

This package needs wget to work. I'll add it as a make-depend later.

nic96 commented on 2018-04-06 03:06

@hunar1997 Maybe the launcher downloaded a newer version of Minceraft PE than is currently supported. Make sure you not a beta tester on play store.

Or maybe try recompiling it since now 1.2.13 support has been added I believe. I'm currently running 1.2.11.

darkfm commented on 2018-03-12 00:06

This actually has a dependency on lib32-libevdev as well.

hunar1997 commented on 2018-03-08 10:52

I did the patch from nic96 and it installed without erros, but now it wont launch, it shows this: <br> Signal 11 received Backtrace elements: 6

0 /opt/mcpelauncher-git/mcpelauncher(_Z12handleSignaliPv+0x84) [0x5673c144]
1 linux-gate.so.1(__kernel_sigreturn+0) [0xf7ef2dd0]
2 /opt/mcpelauncher-git/mcpelauncher(_Z20patchCallInstructionPvS_b+0x20) [0x5673c780]
3 /opt/mcpelauncher-git/mcpelauncher(main+0xbc4) [0x5672cec4]
4 /usr/lib32/libc.so.6(__libc_start_main+0xf3) [0xef750793]
5 /opt/mcpelauncher-git/mcpelauncher(+0x1019e8) [0x5672f9e8]

Dumping stack... Signal 6 received /usr/bin/mcpelauncher: line 15: 20811 Aborted (core dumped) /opt/mcpelauncher-git/mcpelauncher "$@"

nic96 commented on 2018-02-14 02:17

I made some fixes and changes to the PKGBUILD. I made a patch for it https://gist.github.com/nic96/e03b30d7097097409722f964a6c30a69. If you want to apply the patch just download it and run "git apply permission-and-dependency-fix.patch"

Or add me as a co-maintainer and I could apply and commit the patch myself.