Package Details: mecab 0.996-5

Git Clone URL: https://aur.archlinux.org/mecab.git (read-only)
Package Base: mecab
Description: Yet another part-of-speech and morphological analyzer.
Upstream URL: https://taku910.github.io/mecab
Licenses: GPL2
Submitter: FSMaxB
Maintainer: FSMaxB
Last Packager: FSMaxB
Votes: 5
Popularity: 0.241615
First Submitted: 2015-08-12 13:55
Last Updated: 2015-09-17 22:58

Latest Comments

arnold commented on 2015-12-13 03:26

Thank you very much for your work.

itachi17 commented on 2015-09-16 17:23

It seems that mecab is working fine in terminal. However in Firefox, plugin named furigana inserter prints in firefox console(ctrl+shift+j) this: "Error: Error: unsupported character set, only UTF-8 is supported: utf-8." I looked up in the PKGBUILD and there is no --with-charset=utf8 switch. So I compiled it with that but again its not working. Dont you know where's the problem?

FSMaxB commented on 2015-08-12 17:38

Ok, I've updated both packages. mecab now prints a message that you should update mecab-ipadic as well and the pkgrel is bigger than the previous one.

Unfortunately though, dependencies don't support pkgrels, so mecab-ipadic doesn't depend on the new version of the package.

Addile commented on 2015-08-12 17:23

Nice, also there is a mirror of the old pkgbuilds available at http://pkgbuild.com/git/aur-mirror.git/tree/ btw. Might take a bit to fully load though since it's quite big.

FSMaxB commented on 2015-08-12 17:03

@Raphael.Miedl: I didn't even have the old package for reference, I don't know if the old AUR packages are even accessible anymore so I don't have any idea what the previous pkgrel was.

I changed libexec to /usr/lib because it says so in the Arch packaging standards (https://wiki.archlinux.org/index.php/Arch_packaging_standards).

It's not possible to solve the problem with mecab-ipadic using dependencies, because this would be circular, so I'll probably just change the version of mecab-ipadic and mecab and add a message that prompts the user to update mecab-ipadic. But I can make mecab-ipadic depend on the new version of mecab.

Addile commented on 2015-08-12 16:53

thanks for taking over the package, you might want to bump the version number slightly tho so it gets updated.

The old mecab package didn't change libexec to /usr/lib, meaning that your new mecab-ipadic won't find /usr/lib/mecab/mecab-dict-index for example since the old mecab had it in /usr/libexec/mecab/mecab-dict-index.

If you bump the version of this package slightly (maybe additional minor version like mecab-ipadic) it should be updated by aur helpers and install it into the directory you wanted. Instead of keeping the old aur3 package around.

Or maybe not change libexec?

Also what's the reason for using /usr/lib/ instead of /usr/libexec/? (purely out of interest).