Package Details: mediathek 12-3

Git Clone URL: (read-only)
Package Base: mediathek
Description: Offers access to the Mediathek of different german tv stations (ARD, ZDF, Arte, etc.)
Upstream URL:
Licenses: custom
Submitter: None
Maintainer: boenki
Last Packager: boenki
Votes: 135
Popularity: 2.137147
First Submitted: 2010-03-10 21:49
Last Updated: 2016-08-27 20:01

Dependencies (4)

Required by (0)

Sources (3)

Latest Comments

boenki commented on 2016-10-26 12:42

Das Projekt läuft zum Jahresende aus, dann kann das Programm nicht mehr verwendet werden.

boenki commented on 2016-08-27 20:03

thank you, patch is applied

z3ntu commented on 2016-08-27 10:47

As "java-openjfx" is supplied by the package "jdk" (which is the official Oracle Java), you can't start mediathek with "jdk" installed ("jre" is apparently the same). So I propose the following patch:

dvzrv commented on 2016-08-15 09:46

@strubbisch: As mediathekview is dependant on java-openjfx, it is dependant on java-runtime-openjdk=8. Running with the extended PATH should just work fine. I have java-8-openjdk as default atm and had java-7-openjdk before. Could run mediathek view with the extended PATH without any troubles.

strubbisch commented on 2016-08-13 08:14

@boenki: The added code works only when openjdk is installed. I deleted that line again, as I have jdk8 installed and set as default. Then it works.

boenki commented on 2016-08-12 18:11

@dvzrv: done, thank you!

dvzrv commented on 2016-08-12 00:25

@boenki: Would you mind adding

export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH

to the startup script (before starting MediathekView.jar)?
It ensures, that mediathekview is started using openjdk8 (now required) instead of openjdk7.

SammysHP commented on 2016-01-25 21:14

The program asks for the ffmpeg path, but the PKGBUILD has "mplayer" as an optional dependency. Maybe it should be replaced by ffmpeg.

boenki commented on 2015-08-25 13:42

@tinxy: is there anything wrong with my PKGBUILD?

tinxy commented on 2015-08-25 12:15

Version 10


fordprefect commented on 2015-03-02 13:01

@ShalokShalom: thats whats called a duplicate. if you encounter one you may report it by filing a merge request.
now you know…

ShalokShalom commented on 2015-03-02 12:16

Why 2 PKGBUILD`s ?

ShalokShalom commented on 2015-03-02 12:12

Why 2 PKGBUILD`s: ?

gatonero commented on 2014-04-18 13:57

MD5 sum for is b5602b9eed261383a46ad5ce9c7274d7

joschi commented on 2014-04-16 22:10

Updated PKGBUILD for MediathekView 6:

googol commented on 2014-04-14 15:10

Version 6 is released

googol commented on 2014-04-14 15:10

Version 5 is released.

Aldus commented on 2014-04-10 18:19

MD5 sum for is wrong, must be corrected to:

boenki commented on 2014-01-09 07:28

you're right! Moved vlc to optdepends. Thanks!

iord commented on 2014-01-08 23:40

Is there a special reason why vlc is not an optional dependency?
It works perfectly fine for me without it.
(I do not use vlc otherwise ...)

Anonymous comment on 2013-09-18 20:06

A 3.3.0 update script can be downloaded at

woitaschek commented on 2013-09-05 13:15

It crashes without the optional dependency flvstreamer which is also available in the aur.

dsohler commented on 2013-05-03 23:53

Arte+7 provides 720p video, but download only happens with low-quality file.

coolmast commented on 2012-05-15 20:09

I updated the PKGBUILD to the newest version: Works fine for me. Additionally you need to adjust "Mediathek.jar" to "MediathekView.jar" in the provided mediathek file for /usr/bin!

coolmast commented on 2012-05-15 20:00

I updated the PKGBUILD to the newest version: Works fine for me. Additionally you need to adjust "Mediathek.jar" to "MediathekView.jar" in the provided mediathek file for /usr/bin!

Anonymous comment on 2011-09-12 17:13

new version 2.6.0

boenki commented on 2010-11-25 20:39

Now I adopted it. I hope it builds fine everywhere. Comments welcome!

Anonymous comment on 2010-11-25 13:09

I just adopt this package and keep it up to date. it seems, that you (boenki) are more familiar then me with java builds. so i give you the chance to own mediathekview.

boenki commented on 2010-10-31 20:48

Some more things:
1. The pkg needs a .desktop file in /usr/share/applications (see previous comment)
2. Why do you copy ALL the files? We certainly don't need windows executables.
3. It depends (at least optionally) on flystreamer

you may also want to read

Grüße aus Bonn

boenki commented on 2010-10-30 20:37

@sören: why don't you just create a file, put it in the same folder as the PKGBUILD and then just copy it to /usr/bin instead of creating it with cat in the PKGBUILD?! ;)

Anonymous comment on 2010-10-28 17:37


Anonymous comment on 2010-10-09 10:03

new version 2.2.1

Anonymous comment on 2010-09-26 21:11

Have fun with the new version 2.2.0 :D

Anonymous comment on 2010-09-13 21:54

sry for delay! 2.1.5 is online (I skip a few buggy versions)

Anonymous comment on 2010-09-03 12:47

PKGBUILD for mediathek 2.1.2:

Anonymous comment on 2010-08-31 12:23

update will come in a few days

Anonymous comment on 2010-08-29 15:29

New Version 2.1.2 WDR zugefügt

Anonymous comment on 2010-07-06 18:18

updated, thx pew for your PKGBUILD

Anonymous comment on 2010-07-04 17:44

The mail address <> dosn't work, so I wrote to the aur-general mailinglist to become the maintainer. I've prepared a own PKGBUILD, so I just wait of a TU :D

Anonymous comment on 2010-07-01 14:18

...aaand 2.1.1 ;)

Anonymous comment on 2010-05-24 19:10

new PKGBUILD for 2.1.0

Anonymous comment on 2010-04-04 18:39

version 2.0.1 is out with a GTK-Theme and an optimazed search function