Package Details: meld-dev 3.17.4-1

Git Clone URL: https://aur.archlinux.org/meld-dev.git (read-only)
Package Base: meld-dev
Description: Visual diff and merge tool
Upstream URL: http://meldmerge.org/
Licenses: GPL
Conflicts: meld meld-git
Provides: meld
Replaces: meld meld-git
Submitter: mydongistiny
Maintainer: mydongistiny
Last Packager: mydongistiny
Votes: 10
Popularity: 0.493094
First Submitted: 2015-03-15 19:36
Last Updated: 2017-08-26 21:49

Required by (6)

Sources (1)

Latest Comments

chetgurevitch commented on 2017-08-05 03:39

Array entries for replaces and provides should be separated by spaces, not commas which is why the conflict is currently broken. Also the replaces field is only for obsolete packages, as neither meld nor meld-git are obsolete that line should be removed.

btmcg commented on 2017-05-02 01:35

For some reason, I was unable to install this package if I already have the meld package installed. It didn't seem to handle the conflict and remove meld first. I would get the following error:

error: failed to commit transaction (conflicting files)

And then it proceeded to list every file in the meld-dev package:

meld-dev: /usr/bin/meld exists in filesystem

Once I uninstalled meld, I could install meld-dev without a problem.

electricprism commented on 2016-05-13 09:15

When doing a directory comparison

$ meld
(meld:30650): Gtk-WARNING **: Theme directory devices/48 of theme breeze-dark has no size field

Couldn't find colour scheme details for meld:unknown-text-foreground; this is a bad install
--
When using Adwaita

$ meld
Couldn't find colour scheme details for meld:unknown-text-foreground; this is a bad install

--
The issue is caused when using GTK theme Adwaita with dark mode enabled while doing a directory comparison.

mydongistiny commented on 2016-04-01 03:27

@Psykar No, you're not being a pain. I recently re-did the files and obviously I missed some things. I'll fix it and also add the conflicting apps. Thanks again.

Psykar commented on 2016-04-01 03:23

Ah, sorry to be a pain, you also need to update pkgname in your PKGBUILD to match the AUR name here.
(ie meld-dev)

You can use an underscored variable to hold the 'meld' name you need for generating the package URL.

Otherwise pacman will think it's the same package as in the extra repos and complain at you that you've got a more recent version.

Should probably also conflict with meld and meld-git

mydongistiny commented on 2016-04-01 01:59

@Psykar Thanks. I fixed it.

Psykar commented on 2016-04-01 01:17

You've got a mismatch between .SRCINFO and PKGBUILD
.SRCINFO has pkgrel 2, and PKGBUILD has pkgrel 1

mydongistiny commented on 2015-12-06 20:12

I have no problem when using it. Can you please show me what your problem is?

huitseeker commented on 2015-12-01 15:29

This package is affected by : https://bugs.archlinux.org/task/47025 (which renders it unusable) It would be great to patch it.

mydongistiny commented on 2015-11-20 21:48

Done. Thank you.

All comments