Package Details: meld-git 3.21.3.6.g8112b4e8-2

Git Clone URL: https://aur.archlinux.org/meld-git.git (read-only, click to copy)
Package Base: meld-git
Description: Visual diff and merge tool
Upstream URL: http://meldmerge.org/
Licenses: GPL
Conflicts: meld, meld-dev
Provides: meld
Submitter: mydongistiny
Maintainer: mydongistiny
Last Packager: mydongistiny
Votes: 12
Popularity: 0.000126
First Submitted: 2015-11-08 01:15 (UTC)
Last Updated: 2022-09-01 00:23 (UTC)

Latest Comments

1 2 3 Next › Last »

silvio commented on 2022-01-13 14:15 (UTC) (edited on 2022-01-13 14:16 (UTC) by silvio)

@mydongistiny: done! :-D --> https://gitlab.gnome.org/GNOME/meld/-/issues/645

mydongistiny commented on 2022-01-13 14:03 (UTC)

@silvio Please submit the patch upstream to the meld team. It's a problem on their end. They are refactoring/refactored a lot of their build system. I've already submitted one to fix another error. This problem is actually because of the latest version of meson and the deprecation of some options they used to support, but meld needs to fix it. All Gnome maintainers are working right now(and have been for a little while) to remove these errors.

silvio commented on 2022-01-13 13:55 (UTC)

I have following error at build-time:

meld/data/meson.build:34:0: ERROR: Function does not take positional arguments.

After removing of 'appdata' it works again.

Here the patch for this:

diff --git a/data/meson.build b/data/meson.build
index 01949188..de099d3b 100644
--- a/data/meson.build
+++ b/data/meson.build
@@ -32,7 +32,6 @@ if desktop_file_validate.found()
 endif

 appdata_file = i18n.merge_file(
-  'appdata',                                                                              
   input: configure_file(
     input: files('org.gnome.meld.appdata.xml.in.in'),

mydongistiny commented on 2021-07-02 14:14 (UTC)

@Jeffrey4l Ahh okay cool. Glad it's working now. I use a lot of git PKGBUILD's too heh.

Jeffrey4l commented on 2021-07-02 14:11 (UTC)

hey, i found I am using a old xorgproto-git which cause the issue. After xorgproto from extra, meld-git is built successfully.

Jeffrey4l commented on 2021-07-02 14:08 (UTC)

thanks @mydongistiny

I already have glib2 and gtk3 as depends, but still have the same error.

mydongistiny commented on 2021-07-02 14:00 (UTC)

@Jeffrey4l I updated the PKGBUILD and pushed to aur. Looks like they added new deps so I added them. Let me know after makepkg -s if that solved it for you.

Jeffrey4l commented on 2021-07-02 13:45 (UTC)

Got follow errror when building

+ exec meson setup --prefix /usr --libexecdir lib --sbindir bin --buildtype plain --auto-features enabled --wrap-mode nodownload -D b_lto=true -D b_pie=true build -D docs=true -D byte-compile=false
The Meson build system
Version: 0.58.1
Source dir: /tmp/yaourt-tmp-jeffrey/aur-meld-git/src/meld
Build dir: /tmp/yaourt-tmp-jeffrey/aur-meld-git/src/meld/build
Build type: native build
WARNING: Unknown options: "docs"
The value of new options can be set with:
meson setup <builddir> --reconfigure -Dnew_option=new_value ...
Project name: meld
Project version: 3.21.0
Host machine cpu family: x86_64
Host machine cpu: x86_64
Program python3 found: YES (/usr/sbin/python3)
Found pkg-config: /usr/sbin/pkg-config (1.7.3)
Run-time dependency python3 found: YES 3.9
Found CMake: /usr/sbin/cmake (3.20.5)
Run-time dependency gtk+-3.0 found: NO (tried cmake)

meson.build:19:0: ERROR: Could not generate cargs for gtk+-3.0:
Package dependency requirement 'fixesproto >= 6.0' could not be satisfied.
Package 'fixesproto' has version '5.0', required version is '>= 6.0'
Package dependency requirement 'fixesproto >= 6.0' could not be satisfied.
Package 'fixesproto' has version '5.0', required version is '>= 6.0'
Package dependency requirement 'fixesproto >= 6.0' could not be satisfied.
Package 'fixesproto' has version '5.0', required version is '>= 6.0'
Package dependency requirement 'fixesproto >= 6.0' could not be satisfied.
Package 'fixesproto' has version '5.0', required version is '>= 6.0'
Package dependency requirement 'fixesproto >= 6.0' could not be satisfied.
Package 'fixesproto' has version '5.0', required version is '>= 6.0'

mydongistiny commented on 2020-12-15 14:56 (UTC)

@cocoche007 did you rebuild meld-git after updating to python 3.9? Because you have to so it updates the files. I'll change the package version when I get a chance so people are forced to.

Or am I misunderstanding your comment?