Package Details: melvor-mod-manager 0.4.2-1

Git Clone URL: https://aur.archlinux.org/melvor-mod-manager.git (read-only, click to copy)
Package Base: melvor-mod-manager
Description: Melvor Mod Manager (M3) allows you to quickly add userscripts and browser extensions as mods to the Steam edition of Melvor Idle.
Upstream URL: https://github.com/CherryMace/melvor-mod-manager
Licenses: MIT
Submitter: Erin-Allison
Maintainer: None
Last Packager: Erin-Allison
Votes: 1
Popularity: 0.081806
First Submitted: 2021-12-15 16:09 (UTC)
Last Updated: 2022-02-01 18:01 (UTC)

Pinned Comments

Erin-Allison commented on 2022-11-08 13:44 (UTC)

This application is deprecated; official mod support has been built into the base game.

https://github.com/CherryMace/melvor-mod-manager#this-project-is-no-longer-supported-thanks-to-everyone-who-used-and-enjoyed-m3

Latest Comments

Erin-Allison commented on 2022-11-08 13:44 (UTC)

This application is deprecated; official mod support has been built into the base game.

https://github.com/CherryMace/melvor-mod-manager#this-project-is-no-longer-supported-thanks-to-everyone-who-used-and-enjoyed-m3

thenumeralone commented on 2022-09-28 05:43 (UTC)

It looks like upstream is currently broken. To fix it, I used the following diff:

 2 files changed, 6 insertions(+), 5 deletions(-)

diff --git .SRCINFO .SRCINFO
index 9509430..581c200 100644
--- .SRCINFO
+++ .SRCINFO
@@ -4 +4 @@ pkgbase = melvor-mod-manager
-   pkgrel = 1
+   pkgrel = 2
@@ -9,0 +10 @@ pkgbase = melvor-mod-manager
+   makedepends = git
diff --git PKGBUILD PKGBUILD
index 5e2e8cd..b0f0b80 100644
--- PKGBUILD
+++ PKGBUILD
@@ -5 +5 @@ pkgver=0.4.2
-pkgrel=1
+pkgrel=2
@@ -10 +10 @@ url="https://github.com/CherryMace/${pkgname}"
-makedepends=('npm' 'nodejs')
+makedepends=('npm' 'nodejs' 'git')
@@ -23,2 +23,2 @@ build() {
-   npm install
-   npm run electron:build
+   npm install --before 2022-02-01
+   npm run electron:build -- --linux --dir
-- 
2.37.3

thenumeralone commented on 2022-09-28 04:15 (UTC)

Yeah, please add git to makedepends. I build aur packages in a minimal environment by default and not having git in makedepends prevents installation.

MarsSeed commented on 2022-03-24 06:02 (UTC) (edited on 2022-03-24 06:03 (UTC) by MarsSeed)

Please kindly add git to makedepends as it is needed to download source.