Package Details: meme 4.10.2-1

Git Clone URL: (read-only)
Package Base: meme
Description: The MEME suite provides tools for discovering and using protein and DNA sequence motifs
Upstream URL:
Licenses: custom
Submitter: allencch
Maintainer: allencch
Last Packager: allencch
Votes: 6
Popularity: 0.000008
First Submitted: 2012-08-01 05:47
Last Updated: 2015-09-28 15:08

Latest Comments

allencch commented on 2015-09-28 15:09

@sauliusl, Thank you very much for the patch. Are you willing to become the co-maintainer?

sauliusl commented on 2015-09-28 13:29

PKGBUILD to update for 4.10.2:

This also adds a workaround for meme_xml_to_html and other files that meme-chip cannot find once we add a meme- prefix to the binaries.

cyrilccros commented on 2015-05-26 09:30

New version out:

allencch commented on 2014-11-18 00:11

@Carlinix, thanks for the suggestion.

Carlinix commented on 2014-11-17 12:23

I recommend include openmpi as a dependency:

$ meme-meme
meme-meme: error while loading shared libraries: cannot open shared object file: No such file or directory

allencch commented on 2014-07-09 14:46

@vejnar, updated.

vejnar commented on 2014-07-09 14:25

Thanks for the quick update but I had to change it again: same problem with the Perl modules:

allencch commented on 2014-07-09 01:10

@vejnar, thank you for the update of the PKGBUILD. But I have modified a little about it because of the URL and the sha1sum.

vejnar commented on 2014-07-08 21:54

The Python scripts are not working. I updated the PKGBUILD:

vejnar commented on 2014-07-08 21:51

The Python script are not working. I update the PKGBUILD:

vejnar commented on 2014-07-08 21:49

The Python script are not working. I update the PKGBUILD.

#Contributor: allencch <allencch at hotmail dot com>
#Contributor: Charles E. Vejnar
pkgdesc="The MEME suite provides tools for discovering and using protein and DNA sequence motifs"
arch=("i686" "x86_64")
depends=(perl-html-template tcsh python2)

prepare() {
cd $srcdir/${pkgname}_${pkgver%_*}

patch -p1 -i "${srcdir}/python27.patch"

build() {
cd $srcdir/${pkgname}_${pkgver%_*}

./configure --prefix=/usr --program-prefix="meme-" --docdir='${prefix}'/usr/share/doc/meme --sysconfdir='${prefix}'/../etc/meme --with-python=/usr/bin/python2.7


package() {
cd "${srcdir}/${pkgname}_${pkgver%_*}"

make prefix="${pkgdir}/usr" install

# Move Python module to a more standard location
install -dm755 ${pkgdir}/usr/lib/python2.7/site-packages
for fname in $(ls -1 ${pkgdir}/usr/lib/python2.7/); do
if [[ $fname = *.py ]]; then
mv ${pkgdir}/usr/lib/python2.7/$fname ${pkgdir}/usr/lib/python2.7/site-packages/${fname#meme-}

Zorino commented on 2014-01-26 20:12

The latest version is 4.9.1
Thank you.

khughitt commented on 2013-06-12 10:32

Removing the /usr/lib/perl5/site_perl/ directory and installing worked for me. Seems to be an issue with recent Perl upgrade and affected multiple packages.

allencch commented on 2013-06-11 13:29

@khughitt, so far I have no problem for compilation.

khughitt commented on 2013-06-10 09:41

Hmm. running into issues after the recent perl update:

/usr/bin/perl -I ../scripts/ -MCatList -e 'CatList::index_catlist_csv("fasta_db.csv", "fasta_db.index")'
Perl API version v5.16.0 of Encode does not match v5.18.0 at /usr/share/perl5/core_perl/ line 92.
Compilation failed in require at ../scripts/ line 66.
BEGIN failed--compilation aborted at ../scripts/ line 66.
Compilation failed in require.
BEGIN failed--compilation aborted.
make[2]: *** [fasta_db.index] Error 255
make[2]: Leaving directory `/tmp/yaourt-tmp-keith/aur-meme/src/meme_4.9.0/etc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-keith/aur-meme/src/meme_4.9.0'
make: *** [all] Error 2

Any suggestions?

allencch commented on 2013-01-10 23:57

Thanks, talavis.

talavis commented on 2013-01-10 12:35

It seems that they have modified the source; 4.9.0 was available at with md5sum 6b454caf27fbffa08f51dacb6c3930c1.