Package Details: mendeleydesktop-bundled 1.19.6-1

Git Clone URL: https://aur.archlinux.org/mendeleydesktop.git (read-only, click to copy)
Package Base: mendeleydesktop
Description: Academic software for managing and sharing research papers.
Upstream URL: http://www.mendeley.com/release-notes/
Keywords: elsevier mendeley
Licenses: custom:mendeley_eula
Conflicts: mendeleydesktop
Provides: mendeleydesktop
Submitter: lpjhjdh
Maintainer: ali.molaei
Last Packager: ali.molaei
Votes: 298
Popularity: 1.66
First Submitted: 2009-06-10 18:28
Last Updated: 2020-08-29 16:42

Pinned Comments

akstrfn commented on 2018-10-02 15:21

To avoid crashs when opening PDF's, and hangout on exit install mendeleydesktop-bundled which packages Qt provided by the upstream.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

javad commented on 2020-10-03 10:07

@blurredrecluse

I am using a 4k/high-dpi monitor and I am pretty sure that you too. The following command solved my issue:

QT_SCALE_FACTOR=1 QT_AUTO_SCREEN_SCALE_FACTOR=0 mendeleydesktop

It seems that it kind of a bug for gnome desktop as it does not apply the scaling factor for qt apps.

You can also set the follwing lines of code in the set_environment function in the /opt/mendeleydesktop/bin/mendeleydesktop file:

os.environ["QT_SCALE_FACTOR"] = "1"
os.environ["QT_AUTO_SCREEN_SCALE_FACTOR"] = "0"

javad commented on 2020-09-16 19:02

Same issue like the one @blurredrecluse has.

PDFs are bigger in Mendeley Desktop PDF viewer in Manjaro Gnome 3.36. The buttons below main menu also are unusually large! I've tried menedelydektop and menedelydektop-bundled. Actually, menedelydektop does not load so I have to use menedelydektop-bundled.

I've also tested the bundle from the mendeley website, and it didn't solve my issue. Unbelievably, it works like a charm in KDE!

It really bother me as I can't use its own PDF viewer in Gnome!

donpicoro commented on 2020-08-20 14:44

I know this is already flagged as out-of-date but while @xgdgsc is at it maybe we can remove this error

[code] rm: cannot remove 'bin/install-mendeley-link-handler.sh': No such file or directory ==> ERROR: A failure occurred in package_mendeleydesktop(). [/code]

which stems from the line

[code]

TODO Run install-mendeley-link-handler.sh for gconf or just remove it?
rm bin/install-mendeley-link-handler.sh

[/code]

from the PKGBUILD. This should be a simple fix.

Cheers,

/Pico

blurredrecluse commented on 2020-07-06 12:04

Hi all,

I am having an issue viewing PDF files in Mendeley Desktop. The PDF viewer in Mendeley renders text on pages bigger than the page size. I suspect that it has to do with scaling, as I have a HiDPI (3840x2160) display—see the screenshot in the link below.

Any idea on where to start looking for the problem?

Kingpatzer commented on 2020-06-12 18:06

Not sure why this is flagged out of date. Mendeley Desktop is being replaced by Mendeley Reference Manager eventually, but currently Mendeley Desktop has essential functionality that reference Manager is lacking.

monson commented on 2020-03-01 03:51

If setting QT_QPA_PLATFORM=wayland system-wide for other applications, mendeleydesktop will fail to launch because the Qt shipped in mendeleydesktop-bundled doesn't contain wayland QPA. As it only ships xcb QPA, I'm proposing patching mendeleydesktop-bundled's bin/mendeleydesktop to unset QT_QPA_PLATFORM or force QT_QPA_PLATFORM=xcb before launching.

ajkswamy commented on 2020-01-28 11:36

In the latest version, I am not able to open documents within mendeley. A pop up says "Unable to open PDF - it may be". I am nonetheless able to open documents externally.

Edit: Nevermind. The locale of my system was not setup correctly. Works fine now.

akstrfn commented on 2019-10-24 19:05

Just use mendeleydesktop-bundled

rychglenn commented on 2019-10-24 15:14

@akstrfn Anyone news about the @David01's error? I have the same.

akstrfn commented on 2019-10-17 09:37

I am not going to maintain this package anymore since I am switching to Zotero.