Package Details: meson-git 0.63.0rc1.r10.c2c9359d4-1

Git Clone URL: https://aur.archlinux.org/meson-git.git (read-only, click to copy)
Package Base: meson-git
Description: SCons-like build system that use python as a front-end language and Ninja as a building backend
Upstream URL: http://mesonbuild.com/
Licenses: Apache
Conflicts: meson
Provides: meson
Submitter: nontlikeuname
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 8
Popularity: 0.071020
First Submitted: 2016-04-06 19:50 (UTC)
Last Updated: 2022-06-27 00:58 (UTC)

Required by (2762)

Sources (2)

Latest Comments

Salamandar commented on 2020-08-04 15:20 (UTC)

@SolarAquarion this package is unusable in this state. You should remove all those checkdepends.

milkii commented on 2020-08-02 19:55 (UTC) (edited on 2020-08-02 20:20 (UTC) by milkii)

qt4 still? given that's compile-from-source now, can what be removed?

edit: that's a lot of checkdepends. does the build run a test suite itself?

SolarAquarion commented on 2019-07-04 19:56 (UTC)

@salamandar those are "checkdepends" the same story as upstream

Salamandar commented on 2019-07-04 17:13 (UTC)

Please remove most of the dependencies. They are not needed by Meson, just supported (qt, gtk, clang, etc)

commented on 2018-02-02 22:03 (UTC)

Could you please add syntax installation, similar to extra/meson? https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/meson

TingPing commented on 2016-10-20 01:55 (UTC)

> optdepends=('python-pyqt5: GUI support') The GUI no longer exists.