Package Details: metasploit-git 1:4.11.25.38215.891a788-1

Git Clone URL: https://aur.archlinux.org/metasploit-git.git (read-only)
Package Base: metasploit-git
Description: An advanced open-source platform for developing, testing, and using exploit code
Upstream URL: http://www.metasploit.com/
Licenses: BSD
Conflicts: metasploit
Provides: metasploit
Submitter: axper
Maintainer: anthraxx (Shibumi)
Last Packager: anthraxx
Votes: 10
Popularity: 0.137776
First Submitted: 2014-10-19 15:27
Last Updated: 2016-05-05 18:11

Latest Comments

anthraxx commented on 2016-02-20 16:18

@ext: try rebuilding and reinstalling. works fine
@mxgr: i will investigate how that can be achieved without the .git directory as the release tarball also does not provide any so i will not include the .git directory here.

ext commented on 2016-02-20 08:22

$ msfconsole
fatal: Not a git repository (or any of the parent directories): .git
Could not find activesupport-4.0.13 in any of the sources
Run `bundle install` to install missing gems.

mxgr commented on 2015-12-18 12:58

The package() function removes the .git folder. However, a repository is necessary for the msfupdate command to work. There is an error message "Cannot determine checkout type".

If I replace the line:

find . -maxdepth 1 -mindepth 1 -not -path './.git*' -exec cp -r '{}' "${pkgdir}/opt/${pkgname}" \;

with:

find . -maxdepth 1 -mindepth 1 -exec cp -r '{}' "${pkgdir}/opt/${pkgname}" \;

Then msfupdate runs without error.

jgabrito commented on 2015-08-08 15:04

Hi,

The 2015-07-18 update to the PKGBUILD script breaks the packaging. The line:

mkdir -p "${pkgdir}/opt" "${pkgdir}/usr/bin"

should be changed to:

mkdir -p "${pkgdir}/opt/${pkgname}" "${pkgdir}/usr/bin"

Otherwise the main installation directory is not created and the cp's in the next line don't work.

Foryah commented on 2015-07-17 08:06

@Shibumi

Hey, I just wanted to let you know that you still get this error :

find: missing argument to `-exec`

I fixed it the way @p0ng fixed it, namely modify in the metasploit.install file, the update_ruby_deps() function, from this :

update_ruby_deps(){
...
find /opt/metasploit-git/vendor/bundle/ruby -name robots.rb -exec chmod o+r '{} \'
\;
}

to this :


update_ruby_deps(){
...
find /opt/metasploit-git/vendor/bundle/ruby -name robots.rb -exec chmod o+r '{}' \;
}

After that, all works great ;)

Shibumi commented on 2015-05-23 09:50

@dopeadmin

thx for reporting this issue.. I fixed this.

If you get a downgrading-message while upgrading the metasploit-git package this is normal because I had to remove the first part of the versionnumber.

dopeadmin commented on 2015-05-22 16:25

Error: pkgver is not allowed to contain colon,hyphens or whitepsace.
error:pkgver(1) generated an invalid version: blog-20150522.33532.03b70e3
any ideas ?

Shibumi commented on 2015-05-15 12:13

@Knight fixed...

Knight commented on 2015-04-29 11:01

in PKGBUILD

echo "BUNDLE_GEMFILE=/opt/${pkgname}/Gemfile bundle exec ruby (no linebreak)/opt/${pkgname}/`basename "${f}"` \"\$@\"" > ${_msffile}

Shibumi commented on 2015-04-29 09:40

@p0ng

Thx I changed this in the metasploit.install

@Knight

could you please upload your version of the PKGBUILD? Don't know what you mean exactly.

Knight commented on 2015-04-28 10:05

@Shibumi

It seems that the lines written to /usr/bin/msf* should be in one line, otherwise msf* will fail to load the Gem files.

p0ng commented on 2015-04-28 04:42

@Shibumi

The 'find' line was wrong.
update_ruby_deps() {
cd /opt/metasploit-git
bundle install --path vendor/bundle
find /opt/metasploit-git/vendor/bundle/ruby -name robots.rb -exec chmod o+r '{}'
\;
}

I changed for this

update_ruby_deps() {
cd /opt/metasploit-git
bundle install --path vendor/bundle
find /opt/metasploit-git/vendor/bundle/ruby -name robots.rb -exec chmod o+r '{}' \;
}

And works like a charm! :D

Thanks :D

Shibumi commented on 2015-04-27 20:04

I changed the paths in the .install file. should work now. But I still think it would be better when everybody would install the gems for metasploit by his/herself with bundle install instead of doing this per root..

Shibumi commented on 2015-04-27 09:35

Thx currently not at home. Will change this. I don't Like .install maybe it would be better when the user installs the bundles by his/herself

Knight commented on 2015-04-27 09:31

@p0ng
It seems that the path to metasploit in the .INSTALL file is not correct, which should be /opt/metasploit-git instead of /opt/metasploit

p0ng commented on 2015-04-27 03:31

"Houston, we have a problem"

root ~ > /home/p0ng/aur/metasploit-git pacman -U metasploit-git-2015042001.32859.4ffffa5-1-x86_64.pkg.tar
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (1) metasploit-git-2015042001.32859.4ffffa5-1

Total Installed Size: 528.66 MiB

:: Proceed with installation? [Y/n]
(1/1) checking keys in keyring [######################################] 100%
(1/1) checking package integrity [######################################] 100%
(1/1) loading package files [######################################] 100%
(1/1) checking for file conflicts [######################################] 100%
(1/1) checking available disk space [######################################] 100%
(1/1) installing metasploit-git [######################################] 100%
Installing necessary ruby dependencies with ruby-bundle
/tmp/alpm_0EPui7/.INSTALL: line 4: cd: /opt/metasploit: No such file or directory
Don't run Bundler as root. Bundler can ask for sudo if it is needed, and installing your bundle as root will
break this application for all non-root users on this machine.
Could not locate Gemfile
find: missing argument to `-exec'
/tmp/alpm_0EPui7/.INSTALL: line 7: ;: command not found
error: command failed to execute correctly
Optional dependencies for metasploit-git
java-runtime: msfgui support
ruby-pg: database support

What did I do wrong?

Shibumi commented on 2015-04-26 22:28

@anonymous_42
The package should work now. :)

Shibumi commented on 2015-04-23 22:04

sorry for my inactivity.. I know of the error.. I will try to fix this in the next days. Please keep calm and use the stable version (thats up to date)

https://aur.archlinux.org/packages/metasploit

Knight commented on 2015-04-21 07:38

Hi @Shibumi. I got an error here:

Gem::InstallError: metasploit-concern requires Ruby version >= 2.1.

The PKGBUILD need to be updated :)

Shibumi commented on 2015-04-02 21:37

Hello I am the new package maintainer :)

axper commented on 2015-03-11 16:31

Alright guys I am going to be busy lately, feel free to adopt the package.

MrRhum commented on 2015-03-11 10:19

@wertha

Yes metasploit only support version >= 2.1 :

https://github.com/rapid7/metasploit-framework/issues/4602#issuecomment-74906292
https://github.com/darkoperator/MSF-Installer/issues/45

wertha commented on 2015-03-10 20:10

@MrRhum

They moved to 2.1.5 https://github.com/rapid7/metasploit-framework/blob/master/.ruby-version

I don't know if they support also 2.2.0, I know they are still fixing bugs for ruby 2.2 https://github.com/rapid7/metasploit-framework/issues/4818

MrRhum commented on 2015-03-10 13:22

This PKGBUILD is outdated.

Metasploit just passed to Ruby 2.2.0 to fix some bugs.

To fix the install donwload the tarball and install ruby2.

Then do :

"gem install bundler"

Don't forget to add ~/home/you/.gem/ruby/2.2.0/bin to your PATH.

Then edit the PKGBUILD and change the following lines :

find "${pkgdir}/usr/share/${pkgname}/vendor/bundle/ruby/1.9.1/gems/robots-0.10.1" -type f -exec chmod 644 {} \;

to

bundle-1.9 install --deployment

to

bundle install --deployment

#find "${pkgdir}/usr/share/${pkgname}/vendor/bundle/ruby/1.9.1/gems/robots-0.10.1" -type f -exec chmod 644 {} \;

echo "ruby-1.9 /usr/share/${pkgname}/`basename "${f}"` \"\$@\"" > "${_msffile}"

to

echo "ruby /usr/share/${pkgname}/`basename "${f}"` \"\$@\"" > "${_msffile}"

You will have the robots issue so just do :

chmod -R 755 /usr/share/metasploit-git/vendor/bundle/ruby/2.2.0/gems/robots-0.10.1/

And then do :

makepkg

sudo pacman -U ....

And you should run Metasploit, Thanks for this outdated package ! Which is the best for the "git" version...

wertha commented on 2015-03-08 11:19

I'm getting the following error:

Gem::InstallError: metasploit_data_models requires Ruby version >= 2.1.
An error occurred while installing metasploit_data_models (0.23.1), and Bundler cannot
continue.
Make sure that `gem install metasploit_data_models -v '0.23.1'` succeeds before
bundling.

I don't know if ruby 2.2.1 will work on this, since ruby 2.2.1 has broken a few packages for me already. But I did change the dependency to ruby2.1 and ruby2.1-bundler which is ruby 2.1.5, probably using rvm or rbenv could work too but I just used this approach.

I updated:
bundle-1.9 install --deployment to bundle-2.1 install --deployment

find "${pkgdir}/usr/share/${pkgname}/vendor/bundle/ruby/1.9.1/gems/robots-0.10.1" to find "${pkgdir}/usr/share/${pkgname}/vendor/bundle/ruby/2.1.0/gems/robots-0.10.1"

echo "ruby-1.9 /usr/share/${pkgname}... to echo "ruby-2.1 /usr/share/${pkgname}...

axper commented on 2015-02-13 17:18

@teravice
added libpcap as dependency, thanks!

teravice commented on 2015-02-12 22:29

I believe you should add libpcap as a dependency too

axper commented on 2015-01-22 12:51

@zsrkmyn
Added postgresql-libs and sqlite to depends, thanks!

zsrkmyn commented on 2015-01-22 06:30

It seems that the package is missing dependencies: postgresql-libs sqlite.

dmnc commented on 2014-11-20 14:35

... solved by installing postgresql-libs, but I'm not happy with it.

dmnc commented on 2014-11-20 14:22

My installation is crashing due to missing pg but I don't need PostgreSQL support with metasploit (I'm not planning to install PgSQL on my machine). Any clues please? Thanks folks.

----

Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

/opt/ruby1.9/bin/ruby-1.9 extconf.rb
checking for pg_config... no
No pg_config... trying anyway. If building fails, please try again with
--with-pg-config=/path/to/pg_config
checking for libpq-fe.h... no
Can't find the 'libpq-fe.h header
*** extconf.rb failed ***

axper commented on 2014-10-31 16:58

@JKAD
No you don't have to download metasploit git upon update if you don't delete files from $BUILDDIR.

But unfortunately you do have to download the ruby dependencies, as they are not in sources(). Please tell if anyone has a solution for this.

I enabled msfconsole due to many requests, but use it at your own risk.

axper commented on 2014-10-31 16:57

@JKAD
No you have to download metasploit git upon update if you don't delete files from $BUILDDIR.

But unfortunately you do have to download the ruby dependencies, as they are not in sources().

I enabled msfconsole due to many requests, but use it at your own risk.

JKAD commented on 2014-10-31 00:47

do you have to download the whole metasploit git again every time you update?

axper commented on 2014-10-26 18:52

@petterk
Hmm, works for me. Can you post the build output?

petterk commented on 2014-10-26 18:30

build fails complaining about makefile not being created.

axper commented on 2014-10-22 15:19

@SASDOE
You are supposed to update the package by rebuilding, that's the purpose of AUR development packages. msfupdate might break stuff.

You can enable it from the PKGBUILD for yourself, however.

SASDOE commented on 2014-10-22 03:32

What happened to msfupdate?