Package Details: mfe 0.1.7-3

Git Clone URL: https://aur.archlinux.org/mfe.git (read-only)
Package Base: mfe
Description: A simple, GTK+ frontend / launcher for mednafen, written in python.
Upstream URL: http://sourceforge.net/projects/mednafenfe/
Licenses: MIT
Submitter: kagan
Maintainer: shaggytwodope
Last Packager: shaggytwodope
Votes: 35
Popularity: 0.100123
First Submitted: 2008-11-12 00:11
Last Updated: 2015-08-08 23:16

Latest Comments

timdaniel commented on 2014-12-12 22:14

When compiling it says that mfe-0.1.7.tar.gz failed to validate the md5sums.

casa commented on 2013-05-13 13:07

mfe Do not work

Traceback (most recent call last):
File "/usr/bin/mfe", line 6, in <module>
mfe.MednafenFE()
File "/usr/lib/python2.7/site-packages/mfe/mfe.py", line 44, in __init__
self.setup_ui()
File "/usr/lib/python2.7/site-packages/mfe/mfe.py", line 288, in setup_ui
self.vblurcheck.set_active(self.config["vblur"])
File "/usr/lib/python2.7/site-packages/mfe/mfeutil.py", line 186, in __getitem__
return self.config["default"][key]
File "/usr/lib/python2.7/site-packages/configobj.py", line 567, in __getitem__
val = dict.__getitem__(self, key)
KeyError: 'vblur'

Anonymous comment on 2013-04-15 00:48

This package don't compile with pacman 4.1.
I had to modify PKGBUILD to compile successfully.

build() {
cd $startdir/src/$pkgname-$pkgver/
patch -p2 < $startdir/src/$pkgname.patch
python2 setup.py bdist
}

package() {
cd $startdir/src/$pkgname-$pkgver/
python2 setup.py install --root=${pkgdir}
}

casa commented on 2013-03-13 16:42

Traceback (most recent call last):
File "/usr/bin/mfe", line 6, in <module>
mfe.MednafenFE()
File "/usr/lib/python2.7/site-packages/mfe/mfe.py", line 44, in __init__
self.setup_ui()
File "/usr/lib/python2.7/site-packages/mfe/mfe.py", line 288, in setup_ui
self.vblurcheck.set_active(self.config["vblur"])
File "/usr/lib/python2.7/site-packages/mfe/mfeutil.py", line 186, in __getitem__
return self.config["default"][key]
File "/usr/lib/python2.7/site-packages/configobj.py", line 567, in __getitem__
val = dict.__getitem__(self, key)
KeyError: 'vblur'

kagan commented on 2013-03-10 12:11

mfe.py patched. Waiting for a new updated release

Nordlicht commented on 2013-01-30 13:30

Does not work with latest mednafen (0.9.28-1) and aborts with errors when trying to start a game (gba):

Unrecognized argument: -gba.vblur

Anonymous comment on 2012-12-28 01:33

python-configobj is now python2-configobj (https://www.archlinux.org/packages/community/any/python2-configobj/)

AnnS commented on 2012-01-16 16:28

Thank you! This is really great.

kagan commented on 2011-08-01 20:17

Updated to 0.1.7
Thanks, MonkeeSage

Anonymous comment on 2011-08-01 07:58

I just pushed version 0.1.7 upstream (fixes audio volume slider and minor patch that works around from $PATH when looking for mednafen binary.)

All comments