Package Details: mgltools 1.5.6-1

Git Clone URL: (read-only)
Package Base: mgltools
Description: Visualization and analysis of molecular structures; includes AutoDockTools, Vision and PythonMoleculeViewer
Upstream URL:
Licenses: custom
Submitter: mschu
Maintainer: mschu
Last Packager: mschu
Votes: 3
Popularity: 0.000000
First Submitted: 2011-02-17 20:35
Last Updated: 2015-06-12 11:07

Latest Comments

mschu commented on 2015-10-01 22:06

The solution to this is, add the packages that got lost with the AUR4 transition again.

There is some way to access the old pkgs, but I can't remember how. I'll take a look a week or so from now, when I've got a bit more spare time.

kathka commented on 2015-09-30 08:46

As of now I'm unable to install this, since the packages "zsi" and "autodocksuite" are removed from aur. Is there a possible workaround?

cspal commented on 2014-08-06 08:20

I can't run pmv because I get the following error:
$ pmv
Run PMV from /usr/lib/python2.7/site-packages/MGLToolsPckgs/Pmv
Resource file used to customize PMV: /home/cspal/.mgltools/1.5.6/Pmv/_pmvrc
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/MGLToolsPckgs/Pmv/", line 381, in runPmv
title=title, withShell= not interactive, verbose=False, gui=gui)
File "/usr/lib/python2.7/site-packages/MGLToolsPckgs/Pmv/", line 843, in __init__
File "/usr/lib/python2.7/site-packages/MGLToolsPckgs/ViewerFramework/", line 371, in __init__
File "/usr/lib/python2.7/site-packages/MGLToolsPckgs/ViewerFramework/", line 360, in __init__
File "/usr/lib/python2.7/site-packages/MGLToolsPckgs/DejaVu/", line 523, in __init__
File "/usr/lib/python2.7/site-packages/MGLToolsPckgs/DejaVu/", line 103, in loadTogl
toglVersion ='package', 'require', 'Togl','2.0')
TclError: couldn't load file "/usr/lib/python2.7/site-packages/MGLToolsPckgs/opengltk/OpenGL/Tk/Togl/": /usr/lib/python2.7/site-packages/MGLToolsPckgs/opengltk/OpenGL/Tk/Togl/ undefined symbol: tkStubsPtr

Please include this Traceback in your bug report.

hit enter to continue

How can I solve this problem?

cspal commented on 2014-08-06 07:54

I can't run after the installation of mgltools:
pvm, because I get error message:
$ pmv
Run PMV from /usr/lib/python2.7/site-packages/MGLToolsPckgs/Pmv
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/MGLToolsPckgs/Pmv/", line 378, in runPmv
from Pmv.moleculeViewer import MoleculeViewer
File "/usr/lib/python2.7/site-packages/MGLToolsPckgs/Pmv/", line 21, in <module>
from DejaVu.Geom import Geom
File "/usr/lib/python2.7/site-packages/MGLToolsPckgs/DejaVu/", line 200, in <module>
from Viewer import Viewer
File "/usr/lib/python2.7/site-packages/MGLToolsPckgs/DejaVu/", line 53, in <module>
from DejaVu.Camera import Camera
File "/usr/lib/python2.7/site-packages/MGLToolsPckgs/DejaVu/", line 41, in <module>
import Image
ImportError: No module named Image
hit enter to continue

I tried to edit ~/.bashrc file:
export LD_LIBRARY_PATH=/opt/molekel/lib:$LD_LIBRARY_PATH

but that doesn't help.

What is the solution for this problem?

arcanis commented on 2014-02-01 22:27

BTW "python-imaging" has name "python2-imaging" too

Jesin commented on 2014-02-01 21:02

The package python2-pmw is now available in [community], and the package python-pmw is now deprecated, so you should probably update your dependencies the next time you update this package.

mschu commented on 2013-09-10 20:34

The package is currently broken. It requires the python package opengltk, which I can't get to build.

Anonymous comment on 2013-09-04 01:46

The last stable release is 1.5.6 (since 2013/03/08), there is also a unstable release of 1.5.7rc1 (but no source). The news of the website is out of date.

mschu commented on 2013-09-03 09:27

Why was this marked out of date? The website still mentions this version.

If there is a problem with the package (that's not that it is outdated) please at least leave a comment on what doesn't work.

mschu commented on 2011-05-24 22:19

fixed. sorry :-)

Anonymous comment on 2011-05-24 10:17

I think python2-numpy should be in the dependencies for this package to be properly built.