Package Details: micro-git 2.0.12.r8.g1231d242-1

Git Clone URL: https://aur.archlinux.org/micro-git.git (read-only, click to copy)
Package Base: micro-git
Description: A modern and intuitive terminal-based text editor
Upstream URL: https://micro-editor.github.io/
Keywords: micro text-editor
Licenses: MIT
Conflicts: micro, micro-bin, micro-nightly-bin
Provides: micro
Submitter: sukso96100
Maintainer: Levitating
Last Packager: Levitating
Votes: 17
Popularity: 0.000001
First Submitted: 2016-04-27 11:14 (UTC)
Last Updated: 2023-09-19 08:55 (UTC)

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

1 2 3 4 Next › Last »

Levitating commented on 2023-09-19 08:55 (UTC)

@xiota fixed

friday13 commented on 2022-05-06 02:04 (UTC)

Does this package install the current version 2.0.10? Or is it installing version 2.8? https://github.com/zyedidia/micro/releases @sukso96100

Levitating commented on 2021-10-16 19:21 (UTC)

@CyberJack I have been away for from my computer the last few months, but I will come back in a few days and will look into the issue.

CyberJack commented on 2021-08-31 11:47 (UTC) (edited on 2021-08-31 11:48 (UTC) by CyberJack)

I am getting this error:

==> Starting package()...  
install: cannot stat '/home/..../micro-git/src/micro-git/micro': No such file or directory

Recent changes to the Makefile broke the build process because it's lacking a proper default.
Updating the PKGBUILD file and calling "make build" instead of "make" solves the problem.

relrel commented on 2021-02-12 10:54 (UTC)

Please change url to https://micro-editor.github.io/.

kseistrup commented on 2020-02-10 16:04 (UTC)

Thanks!

Jake commented on 2020-02-10 12:18 (UTC)

@kseistrup: Yes, it picked up the short commit hash as version number. Should be fixed now, at least it works with yay.

kseistrup commented on 2020-02-10 10:54 (UTC)

The version thing is still wrong: current AUR repos is v2.0.0.rc3.63046ae9-1 and current git version tuirns out as v2.0.0.rc3.00205aa6-1, so any package manager will assume that the package needs an update no matter how many time you install it.

The pkgver function needs to make a monotonously increasing version string. At the moment it doesn't because the next to last component is a random hex string in the interval 00000000-ffffffff.

Mel commented on 2020-01-22 13:56 (UTC)

Same for aurutils:

==> Using [loonix] repository
  -> micro-git: v2.0.0.rc2.1dc1c655-1 -> v2.0.0.rc2.97ee3442-1
==> Retrieving package files
From https://aur.archlinux.org/micro-git
 = [up to date]      master     -> origin/master
==> WARNING: skipping built package (use -f to overwrite)
/var/cache/pacman/loonix/micro-git-v2.0.0.rc2.1dc1c655-1-x86_64.pkg.tar