Package Details: mididings 20120419-2

Git Clone URL: https://aur.archlinux.org/mididings.git (read-only)
Package Base: mididings
Description: A MIDI router and processor based on Python, supporting ALSA and JACK MIDI
Upstream URL: http://das.nasophon.de/mididings/
Licenses: GPL
Submitter: speps
Maintainer: None
Last Packager: leonardder
Votes: 11
Popularity: 0.037689
First Submitted: 2010-08-03 23:03
Last Updated: 2017-06-29 17:04

Dependencies (8)

Required by (0)

Sources (1)

Pinned Comments

leonardder commented on 2017-06-29 17:34

I decided to go back to Python 2, it seems this works probably with the newest version of Boost. Mididings now also lives on GIT, but I can't get it to work for both Python2 and Python3 there.

Latest Comments

leonardder commented on 2017-06-29 17:34

I decided to go back to Python 2, it seems this works probably with the newest version of Boost. Mididings now also lives on GIT, but I can't get it to work for both Python2 and Python3 there.

schubert commented on 2017-06-11 02:38

@habys with boost and boost-libs 1.64 I am not able to import the library either, with the same failure. However, using an older mididings compiled against boost 1.63 does work as a workaround.

habys commented on 2017-06-03 03:24

Anyone not able to import this library?

[luke@ultra-arikui bin]$ cat transpose.py
#!/usr/bin/env python3
from mididings import *

run(Transpose(3))
[luke@ultra-arikui bin]$ ./transpose.py
Traceback (most recent call last):
File "./transpose.py", line 2, in <module>
from mididings import *
File "/usr/lib/python3.6/site-packages/mididings/__init__.py", line 13, in <module>
from mididings.setup import config, hook
File "/usr/lib/python3.6/site-packages/mididings/setup.py", line 13, in <module>
import _mididings
ImportError: dynamic module does not define module export function (PyInit__mididings)

speps commented on 2013-08-09 22:43

Updated to 20120419-1 - now mididings relies completely on python 3
@integer thanks for reporting

integer0 commented on 2013-08-09 14:53

Easy update:

4c4
< pkgver=20120312
---
> pkgver=20120419
16c16
< md5sums=('139e46ff590bcf7136c2820075a972f3')
---
> md5sums=('5d4b642a1b76817b742f01cda60c0a3f')

speps commented on 2011-05-11 23:11

@Nareto Thanks, added boost as makedepend without bumping pkgrel - cheers

Nareto commented on 2011-05-11 08:54

also "boost" is needed to build, otherwise you get an error of file cstdint.hpp not found