Package Details: minecraft latest-29

Git Clone URL: https://aur.archlinux.org/minecraft.git (read-only)
Package Base: minecraft
Description: An open-world game whose gameplay revolves around breaking and placing blocks
Upstream URL: http://www.minecraft.net/
Keywords: game minecraft
Licenses: custom
Submitter: BombStrike
Maintainer: BombStrike
Last Packager: BombStrike
Votes: 647
Popularity: 2.214049
First Submitted: 2010-08-05 16:24
Last Updated: 2017-12-01 07:56

Dependencies (4)

Required by (9)

Sources (6)

Pinned Comments

BombStrike commented on 2018-03-26 03:57

Ok this is still getting flagged as out of date so I'll explain it again:

This package is the official stable package you get when you go through the Minecraft website, which still points to "http://s3.amazonaws.com/Minecraft.Download/launcher/Minecraft.jar"

If you want the new launcher check the https://aur.archlinux.org/packages/minecraft-launcher package that is maintained by Mojang themselves.

And if you want this package to be the new launcher, just ask Mojang why 2.x is not deemed stable yet and if it is if they could update their links on the official website.

I trust that in time I will be able to update this package to the latest launcher but right now it will stay on this version.

Thank you for your understanding.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

BombStrike commented on 2017-11-30 08:50

Sorry about the delay, I updated java-runtime to jre8-openjdk and made the binary use it by default (initially wanted to leave support for the JRE9 but seems to crash the game).

I wish there was a more elegant solution that would be compatible with people using the oracle jre8 but I have no way to say something like "java-runtime == 8" so that will have to do for now.

anoa commented on 2017-10-18 05:48

For anyone getting the "JAVA Unsupported major.minor version 52.0" error, that is because minecraft switched to Java 8 in the 1.12 update. To fix, do the following:

sudo pacman -S jre8-openjdk jre8-openjdk-headless
sudo archlinux-java set java-8-openjdk/jre

Then you should be good.

Package should probably depend on the above packages as well to ensure it works on the latest version, while keeping the previous version as option for older versions.

sylveon commented on 2017-08-13 22:01

I added "StartupWMClass=sun-awt-X11-XFramePeer" to the .desktop file and all the minecraft windows (launcher, bootstrap, game) shows under the same icon in the gnome dock now. Haven't encountered any conflicts (although that's probably because I am not using any other Java application)

BombStrike commented on 2017-07-25 06:17

@cleviojr this is the launcher linked on the minecraft homepage, as soon as the staging launcher becomes the official one then this package will be updated to point to it

cleviojr commented on 2017-07-25 02:44

this seems to be an outdated launcher, for the new one install minecraft-launcher package instead. link: https://aur.archlinux.org/packages/minecraft-launcher/

alexjj commented on 2017-06-21 21:38

Minecraft requires OpenJDK 8 to run now...or I should say it didn't work with 7 for me and installing 8 fixed it.

FraGag commented on 2017-02-05 03:17

You're not actually using that MC_VERSION_URL variable in /usr/bin/minecraft. :)

BombStrike commented on 2017-01-30 02:09

Ok pushed a new version that should fix things, expect a launcher download.

Also added a MC_FORCE_UPDATE environment variable that can be set to force a launcher update (but shouldn't be necessary).

BombStrike commented on 2017-01-30 02:01

For some weird reason if we use the launcher directly from the .minecraft folder it will never update.

I'm adding a small mechanism to automatically redownload the launcher when the game itself gets updated and will push it soon.

In the meantime run "exec java -jar /usr/share/minecraft/Minecraft.jar" manually to force an update

TripleSpeeder commented on 2017-01-29 15:20

Can't start with client version 1.11.2. Gives following error:
[16:16:21 ERROR]: An update to your launcher is available and is required to play 1.11.2. Please restart your launcher.

Flagged package as out-of-date :-)