Package Details: mingw-w64-bullet 2.83.7-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-bullet.git (read-only)
Package Base: mingw-w64-bullet
Description: A 3D Collision Detection and Rigid Body Dynamics Library for games and animation (mingw-w64)
Upstream URL: http://www.bulletphysics.com/Bullet/
Licenses: custom:zlib
Submitter: naelstrof
Maintainer: xantares
Last Packager: xantares
Votes: 4
Popularity: 0.001395
First Submitted: 2012-08-06 04:48
Last Updated: 2016-03-09 20:11

Latest Comments

xantares commented on 2013-11-25 09:27

Seem to be related to:
https://bugzilla.redhat.com/show_bug.cgi?id=843436

naelstrof commented on 2013-11-25 02:54

Not in the position to test it currently, sorry. I'll relinquish ownership until I can.

xantares commented on 2013-11-21 10:34

Hello,

I cannot compile a simple example (see mingw-w64-testsuite):
https://github.com/xantares/pkgtest/blob/master/t_bullet.cxx

xan.

naelstrof commented on 2013-10-30 00:36

Done, thanks for the input.

xantares commented on 2013-10-29 07:47

Hello,
- mingw-w64-cmake pulls mingw-w64-gcc so you can list only mingw-w64-cmake in deps
- care to add 'staticlibs' to options ?
x.

naelstrof commented on 2013-10-27 04:04

Oh thank you ant32, I've been needing that! mingw-w64-gcc was a pain in the ass to keep working via AUR.

Now that I have a working mingw-w64-gcc I've updated bullet. Sorry that it took so long. :)

ant32 commented on 2013-10-26 21:26

I think my repo is in fairly good shape. http://sourceforge.net/p/mingw-w64-archlinux/wiki

naelstrof commented on 2013-10-26 16:40

Sorry right now my mingw-w64-gcc is broken due to the last update. I'll try to fix this asap.

xantares commented on 2013-10-25 09:38

You could pass -DCMAKE_CXX_FLAGS_RELEASE="-fpermissive"

xantares commented on 2013-10-25 09:37

You could pass -DCMAKE_CXX_FLAGS_RELEASE="-fnopermissive"

ant32 commented on 2013-10-25 02:26

The link does not work it is r2704 instead of r2703. Changing it, it builds fine the 32bit but fails while building 64bit. See Log file here http://arch.linuxx.org/logs/20131025-0211-mingw-w64-bullet.log.tar.gz.

Shouldn't you wait to upgrade to 2.82 till the native package is updated? https://www.archlinux.org/packages/community/x86_64/bullet

I did try building 2.81 but ended up with the same error. See log file here http://arch.linuxx.org/logs/20131025-0222-mingw-w64-bullet.log.tar.gz

[ 75%] Building CXX object Extras/Serialize/BulletFileLoader/CMakeFiles/BulletFileLoader.dir/bDNA.obj
/build/mingw-w64-bullet/src/bullet-2.81-rev2613/Extras/Serialize/BulletFileLoader/bDNA.cpp: In member function 'void bParse::bDNA::init(char*, int, bool)':
/build/mingw-w64-bullet/src/bullet-2.81-rev2613/Extras/Serialize/BulletFileLoader/bDNA.cpp:390:13: error: cast from 'char*' to 'long int' loses precision [-fpermissive]
nr= (long)cp;

naelstrof commented on 2013-10-24 14:56

>:(

I'm not able to test it at the moment since I'm at school. It should work though.

xantares commented on 2013-10-24 07:04

Nope :]
2.82 is available

naelstrof commented on 2013-10-23 17:55

You got it.

xantares commented on 2013-10-23 14:25

Hello,

- You can use mingw-w64-cmake wrapper package.
- Please strip libraries.

x.

ant32 commented on 2013-07-30 00:36

@xop this PKGBUILD uses gcc 4.7.4 https://gist.github.com/ant32/6109115
It would be probably be good to file a bug report at gcc.

xop commented on 2013-04-18 11:15

Bullet fails to compile with mingw-w64-gcc-4.8 with following error:

mingw-w64-bullet/src/bullet-2.81-rev2613/src/BulletCollision/CollisionDispatch/btInternalEdgeUtility.cpp:310:2: internal compiler error: Segmentation fault

naelstrof commented on 2012-11-02 17:53

Thanks. I removed mingw-w64-binutils from the dependencies and updated the package.

rubenvb commented on 2012-11-01 12:45

This should not depend on mingw-w64-binutils. See https://wiki.archlinux.org/index.php/MinGW_PKGBUILD_Guidelines#Packaging_2