Package Details: mingw-w64-extra-cmake-modules 5.60.0-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-extra-cmake-modules.git (read-only)
Package Base: mingw-w64-extra-cmake-modules
Description: Extra modules and scripts for CMake (mingw-w64)
Upstream URL: https://community.kde.org/Frameworks
Keywords: extra-cmake-modules kde mingw mingw-w64
Licenses: LGPL
Groups: mingw-w64-kf5
Submitter: Schala
Maintainer: Martchus
Last Packager: Martchus
Votes: 8
Popularity: 0.091511
First Submitted: 2015-06-15 23:30
Last Updated: 2019-07-15 09:23

Latest Comments

tsdgeos commented on 2019-06-25 21:25

I'm going to orphan it since i don't really have time to maintain it.

Please adapt it and give it love :)

Martchus commented on 2019-06-25 12:06

Here's an update: https://github.com/Martchus/PKGBUILDs/blob/master/extra-cmake-modules/mingw-w64/PKGBUILD

Maybe you want me to add as co-maintainer?

xantares commented on 2018-08-10 06:43

  • the arch-cmake macro already sets CMAKE_BUILD_TYPE=Release

tsdgeos commented on 2018-03-07 10:01

Could you update to 5.43? or maybe even 5.44 that will be out in a week :D

Schala commented on 2016-12-30 23:50

Seems to have donew it. Thanks!

Martchus commented on 2016-12-30 22:07

I amended the patch: https://github.com/Martchus/extra-cmake-modules/commit/05aa27dc0e14dab407379a4d22f895e9eff13cc0.patch

Hope all occurrences are fixed now. Of course the issue will occur everywhere where those targets are used. Already asked on CMake IRC channel about the issue but didn't get any response.

Schala commented on 2016-12-29 23:52

Hmm... complaining about lrelease now

Martchus commented on 2016-12-29 13:02

@Schala The following patch might fix the Qt Linguist issue with CMake: https://github.com/Martchus/extra-cmake-modules/commit/e4c8c735d59f813acc69194030401f67883fb427.patch

Of course it is not nice to just workaround the issue, but it is the best I can do for now.

Huulivoide commented on 2016-04-18 12:13

I think mingw-w64-cmake should be a proper dependency, instead of
a build only dep, for this, as this package is useless if one
doesn't have the proper cmake package installed.