Package Details: mingw-w64-ffmpeg 1:4.4-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-ffmpeg.git (read-only, click to copy)
Package Base: mingw-w64-ffmpeg
Description: Complete solution to record, convert and stream audio and video (mingw-w64)
Upstream URL: https://ffmpeg.org/
Licenses: GPL3
Submitter: kfg
Maintainer: kfg
Last Packager: kfg
Votes: 7
Popularity: 0.000002
First Submitted: 2013-06-19 17:10
Last Updated: 2021-05-11 17:31

Latest Comments

« First ‹ Previous 1 2 3

ant32 commented on 2013-12-23 03:59

==> Starting build()...
ERROR: freetype2 not found

If you think configure made a mistake, make sure you are using the latest
version from Git. If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solving the problem.

kfg commented on 2013-11-15 22:44

i don't know what you mean by that:
- there should be any .lib files in <arch>/bin, are they dlls ?

the .lib files are in <arch>/lib and they are static libraries

xantares commented on 2013-11-15 10:23

- mingw-w64-pkg-config should only be listed as makedepends
- there should be any .lib files in <arch>/bin, are they dlls ?
- please add quotes around ${pkgdir} and ${srcdir}

xantares commented on 2013-11-15 10:22

- mingw-w64-pkg-config should only be listed as makedepends
- there should be any .lib files in <arch>/bin, are they dlls ?

ant32 commented on 2013-09-12 20:32

I haven't been able to compile this the last few weeks. This describes my issue http://sourceforge.net/mailarchive/message.php?msg_id=31365439. A workaround for now might be to use mingw-w64-{crt,headers}-secure.

Schala commented on 2013-07-31 00:02

There seems to be static libraries put in the bin directory. They should be in lib

kfg commented on 2013-07-07 07:49

Updated. Thanks for figuring this out.

Btw you probably also need to reinstall mingw-w64-libvpx. The old version produced broken dlls.

ant32 commented on 2013-07-06 19:26

Installing mingw-w64-pkg-config fixed the problem. Could you please add it to the depends? Here is the log from before installing mingw-w64-pkg-config https://dl.dropboxusercontent.com/u/33784287/aur/mingw-w64-ffmpeg_config.log

kfg commented on 2013-07-06 07:31

You should only need mingw-w64-fontconfig.

Please post the config.log from src/build-i686-w64-mingw32 and/or src/build-x86_64-w64-mingw32.

Also I forgot to add mingw-w64-zlib to the dependencies.

ant32 commented on 2013-07-06 02:52

I'm getting this error. I already tried installing the native fontconfig packages.
==> Extracting sources...
-> Extracting ffmpeg-1.2.1.tar.bz2 with bsdtar
==> Starting build()...
ERROR: fontconfig not found