Package Details: mingw-w64-flac 1.4.2-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-flac.git (read-only, click to copy)
Package Base: mingw-w64-flac
Description: Free Lossless Audio Codec (mingw-w64)
Upstream URL: http://flac.sourceforge.net/
Licenses: GPL, BSD
Submitter: naelstrof
Maintainer: Vaporeon
Last Packager: Vaporeon
Votes: 9
Popularity: 0.010597
First Submitted: 2012-07-28 21:27 (UTC)
Last Updated: 2022-10-22 21:10 (UTC)

Pinned Comments

Vaporeon commented on 2022-06-27 19:36 (UTC)

For those having trouble static linking with this version, you now have to define FLAC__NO_DLL somewhere in the project that is using FLAC. See GitHUb issue [1] for more information.

[1] https://github.com/xiph/flac/issues/312

Latest Comments

1 2 Next › Last »

Vaporeon commented on 2022-09-11 17:30 (UTC)

I'll push 1.4.0 when mingw-w64-libogg gets bumped, because depending on how it gets built controls what the DLL name will be.

Vaporeon commented on 2022-06-27 19:36 (UTC)

For those having trouble static linking with this version, you now have to define FLAC__NO_DLL somewhere in the project that is using FLAC. See GitHUb issue [1] for more information.

[1] https://github.com/xiph/flac/issues/312

Vaporeon commented on 2022-06-27 03:46 (UTC)

The installed cmake configuration points to the shared libs, while the static libs exist in the same prefix as the shared libs as before.

This means cmake will fail to find the static libs without workarounds.

I'm not sure what the best thing to do here is as AUR mingw packages as a whole are not consistent.

We have: static libs mixed with shared libs, -static packages that put static libs in a standalone prefix, and -static packages that use the default prefix and conflict with shared packages.

xantares commented on 2015-04-17 12:14 (UTC)

hi, this builds if I use $arch-configure from package mingw-w64-configure: mkdir -p build-${_arch} && pushd build-${_arch} ${_arch}-configure --disable-xmms-plugin --disable-sse --disable-rpath --disable-asm-optimizations --with-pic make popd please update or orphan xan.

localuser commented on 2015-03-11 07:18 (UTC)

@xantares and @naelstrof : This package needs to have automake-1.14 in its dependency list.

xantares commented on 2015-02-21 10:03 (UTC)

hello, it doesnt build unless i uncomment autogen.sh : WARNING: 'aclocal-1.14' is missing on your system. You should only need it if you modified 'acinclude.m4' or 'configure.ac' or m4 files included by 'configure.ac'. The 'aclocal' program is part of the GNU Automake package: <http://www.gnu.org/software/automake> It also requires GNU Autoconf, GNU m4 and Perl in order to run: <http://www.gnu.org/software/autoconf> <http://www.gnu.org/software/m4/> <http://www.perl.org/> Makefile:437: recipe for target 'aclocal.m4' failed

xantares commented on 2014-12-10 08:28 (UTC)

hi, could you use mingw-w64-configure in this one too ? xan.

naelstrof commented on 2014-10-15 21:10 (UTC)

Not sure why this package was marked out of date, the version is right and it compiles fine. I compared it to the PKGBUILD of extra/flac and simply fixed the licenses and upped the pkgrel to match extra/flac.

naelstrof commented on 2013-11-25 02:57 (UTC)

Done

Schala commented on 2013-10-31 04:43 (UTC)

staticlibs option needs to be added, '!libtool' is now default