Package Details: mingw-w64-flac 1.3.1-5

Git Clone URL: https://aur.archlinux.org/mingw-w64-flac.git (read-only)
Package Base: mingw-w64-flac
Description: Free Lossless Audio Codec (mingw-w64)
Upstream URL: http://flac.sourceforge.net/
Licenses: GPL, BSD
Submitter: naelstrof
Maintainer: xantares
Last Packager: xantares
Votes: 8
Popularity: 0.373318
First Submitted: 2012-07-28 21:27
Last Updated: 2015-06-08 20:47

Latest Comments

xantares commented on 2015-04-17 12:14

hi,

this builds if I use $arch-configure from package mingw-w64-configure:
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure --disable-xmms-plugin --disable-sse --disable-rpath --disable-asm-optimizations --with-pic
make
popd

please update or orphan
xan.

localuser commented on 2015-03-11 07:18

@xantares and @naelstrof : This package needs to have automake-1.14 in its dependency list.

xantares commented on 2015-02-21 10:03

hello,
it doesnt build unless i uncomment autogen.sh :
WARNING: 'aclocal-1.14' is missing on your system.
You should only need it if you modified 'acinclude.m4' or
'configure.ac' or m4 files included by 'configure.ac'.
The 'aclocal' program is part of the GNU Automake package:
<http://www.gnu.org/software/automake>
It also requires GNU Autoconf, GNU m4 and Perl in order to run:
<http://www.gnu.org/software/autoconf>
<http://www.gnu.org/software/m4/>
<http://www.perl.org/>
Makefile:437: recipe for target 'aclocal.m4' failed


xantares commented on 2014-12-10 08:28

hi,
could you use mingw-w64-configure in this one too ?
xan.

naelstrof commented on 2014-10-15 21:10

Not sure why this package was marked out of date, the version is right and it compiles fine. I compared it to the PKGBUILD of extra/flac and simply fixed the licenses and upped the pkgrel to match extra/flac.

naelstrof commented on 2013-11-25 02:57

Done

Schala commented on 2013-10-31 04:43

staticlibs option needs to be added, '!libtool' is now default

naelstrof commented on 2013-10-21 19:34

Added stripping, also the mingw-w64-xmms package came from the original mingw32-flac package. I just never created the mingw-w64 version of xmms myself because I've never needed it.

ant32 commented on 2013-10-18 23:01

The package mingw-w64-xmms does not exist. I'm not sure if this is any problem.

xantares commented on 2013-10-08 13:49

hi,
the libraries are not strippped, please add this :
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
x.

naelstrof commented on 2013-06-28 17:13

Alright thanks, that worked great.

Schala commented on 2013-06-26 23:38

Also, Pacman won't detect that 1.3.0 is newer than the git date version this previously used. I suggest putting epoch=1 in the PKGBUILD. This helps to tell Pacman that the package is newer when pkgver indicates a lesser version.

using pkgver: 20090315 > 1.3.0
using epoch: 20090315 < 1:1.3.0

Schala commented on 2013-05-28 19:29

Marked this out of date since 1.3 just came out and should allow for a non-git build again.

naelstrof commented on 2013-04-07 01:08

I thought the only thing deprecated was not having a package() function. I was attempting to make this package non-git, however the non-git version doesn't compile any .dll which are required for Alure.

I'll append -git to the package name, and I'll look at the pacman 4.1 changes to see what else I could be missing in the PKGBUILD. Thanks for mentioning this!

Schala commented on 2013-04-06 23:50

Can you update this to reflect the Pacman 4.1 changes? You can see my PKGBUILDs if you need help. Also, add a -git suffix to the package name. I got some of my packages deleted by a very fussy TU not too long ago for forgetting that.