Package Details: mingw-w64-gcc-bin 8.3.0-3

Git Clone URL: https://aur.archlinux.org/mingw-w64-gcc-bin.git (read-only)
Package Base: mingw-w64-gcc-bin
Description: Cross GCC for the MinGW-w64 cross-compiler (pre-compiled)
Upstream URL: https://gcc.gnu.org/
Keywords: gcc mingw-w64
Licenses: GPL
Groups: mingw-w64, mingw-w64-toolchain
Conflicts: mingw-w64-gcc
Provides: mingw-w64-gcc=8.3.0, mingw-w64-gcc-base
Submitter: 4shadoww
Maintainer: 4shadoww
Last Packager: 4shadoww
Votes: 11
Popularity: 0.170171
First Submitted: 2018-03-21 21:04
Last Updated: 2019-03-08 17:02

Required by (187)

Sources (1)

Pinned Comments

4shadoww commented on 2018-03-22 06:45

Most aur helpers doesn't install the pre-compiled dependecies. So if you want to install pre-compiled dependencies and not install bootstraps and compile your own you will have to install those one by one in this order:

  1. mingw-w64-binutils-bin
  2. mingw-w64-headers-bin
  3. mingw-w64-crt-bin
  4. mingw-w64-winpthreads-bin

Latest Comments

4shadoww commented on 2018-12-21 17:06

@FreddieChopin Make sure to make a clean build. The new source has exactly the same file name as the last one and the build will fail with the old one.

FreddieChopin commented on 2018-12-17 16:04

There seems to be a problem with the last version:

==> Making package: mingw-w64-gcc-bin 8.2.0-3 (pon, 17 gru 2018, 17:02:54)
==> Retrieving sources...
  -> Found mingw-w64-gcc-8.2.0.tar.xz
==> Validating source files with md5sums...
    mingw-w64-gcc-8.2.0.tar.xz ... FAILED
==> ERROR: One or more files did not pass the validity check!
Error downloading sources: mingw-w64-gcc-bin

Sven commented on 2018-11-06 01:46

This package should provide mingw-w64-gcc-base. This would allow using the *-bin packages to bootstrap the compilation of mingw-w64-crt.

eimis commented on 2018-05-18 18:51

thanks man. compiling my own projects gives me enough headaches.

4shadoww commented on 2018-03-22 06:45

Most aur helpers doesn't install the pre-compiled dependecies. So if you want to install pre-compiled dependencies and not install bootstraps and compile your own you will have to install those one by one in this order:

  1. mingw-w64-binutils-bin
  2. mingw-w64-headers-bin
  3. mingw-w64-crt-bin
  4. mingw-w64-winpthreads-bin