Package Details: mingw-w64-glib2 2.66.2-1

Git Clone URL: https://aur.archlinux.org/mingw-w64-glib2.git (read-only, click to copy)
Package Base: mingw-w64-glib2
Description: Low level core library (mingw-w64)
Upstream URL: https://wiki.gnome.org/Projects/GLib
Keywords: glib2 gnome gtk gtk2 gtk3 mingw mingw-w64
Licenses: LGPL2.1
Submitter: brcha
Maintainer: drakkan
Last Packager: drakkan
Votes: 19
Popularity: 0.001378
First Submitted: 2012-06-13 19:15
Last Updated: 2020-10-20 16:00

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 Next › Last »

xantares commented on 2013-10-07 12:36

Hi,
There are useless libtool (.la) files in arch/lib
x.

ekpyron commented on 2013-09-06 00:07

@ant32
http://userpage.fu-berlin.de/mokaga/mingw-w64-glib2-2.37.7-1.src.tar.gz
This tarball at least works for me.

ant32 commented on 2013-09-05 23:52

@ekpyron could you post a src tarball for others. Brcha won't be doing much for a week or two.

ekpyron commented on 2013-09-05 23:42

Please update to 2.37.7 and remove the no longer necessary glib-formatstring.patch. The current PKGBUILD doesn't work for me, but with these little changes everything works fine.

Schala commented on 2013-04-17 22:51

Sounds reasonable I guess

brcha commented on 2013-03-15 21:46

Can I add a negative dependency somehow? Perhaps put plibc into conflicts array?

Schala commented on 2013-03-15 21:44

Yep, plibc was the culprit. It builds fine now.

brcha commented on 2013-03-15 11:22

local/mingw-w64-plibc 0.1.7-1
A POSIX compliant libc for Windows

I don't have that and nl_langinfo should be from libc. Could you try removing mingw-w64-plibc and trying to recompile glib2?

Schala commented on 2013-03-15 05:40

pacman -Qs mingw-w64: http://pastebin.com/r9dDhg2Q
build log: http://pastebin.com/HtntcSbS

brcha commented on 2013-01-22 18:25

@Schala, I have no idea what is the problem. It compiles prefectly on my system. Could you provide some more info, like output of "pacman -Qs mingw-w64" and a complete build log?