Package Details: mingw-w64-libpsl 0.21.2-2

Git Clone URL: https://aur.archlinux.org/mingw-w64-libpsl.git (read-only, click to copy)
Package Base: mingw-w64-libpsl
Description: Public Suffix List library (mingw-w64)
Upstream URL: https://github.com/rockdaboot/libpsl
Licenses: MIT
Submitter: drakkan
Maintainer: drakkan
Last Packager: drakkan
Votes: 3
Popularity: 0.000004
First Submitted: 2018-09-04 12:19 (UTC)
Last Updated: 2023-01-18 20:16 (UTC)

Latest Comments

drakkan commented on 2023-01-18 20:18 (UTC)

should work now, sorry for the trouble

Martchus commented on 2023-01-18 19:48 (UTC) (edited on 2023-01-18 19:50 (UTC) by Martchus)

==> Starting build()...
~/mingw-w64-libpsl/src/libpsl-0.21.2/build-i686-w64-mingw32 ~/mingw-w64-libpsl/src/libpsl-0.21.2
/startdir/PKGBUILD: line 30: i686-w64-mingw32-meson: command not found
==> ERROR: A failure occurred in build().

mingw-w64-configure needs to be replaced with mingw-w64-meson.

vtorri commented on 2022-05-23 07:00 (UTC)

is it possible to use meson instead of configure ? meson is by far faster than autotools. Thank you

davidalb97 commented on 2022-04-02 19:39 (UTC) (edited on 2022-04-02 19:40 (UTC) by davidalb97)

I can confirm that @madmanfred's solution of installing gtk-doc fixes the build on KDE.

madmanfred commented on 2021-01-02 10:17 (UTC)

The package fails to build for me, when i have not installed gtk-doc, so that should probably be in makedepends.

xantares commented on 2019-05-03 14:08 (UTC)

hello, you can drop mingw-w64-gcc now that stack protection is disabled

xantares commented on 2018-09-06 08:03 (UTC)

oh... right

drakkan commented on 2018-09-04 13:13 (UTC)

libpsl-5.dll depends on libssp-0.dll and so mingw-w64-gcc, you should check your packages too :), many ones unexpectedly depend on gcc at runtime

xantares commented on 2018-09-04 12:52 (UTC)

Hi, I doubt it depends on mingw-w64-gcc. xan.